Port in deployment not recognized

Hello friends,

im currently fooling arround with migrating an deployment to maesh. In this process i annotated asrequired my service with the maesh label. But trying to curl the service afterwards fails.

The old address(in my example) with http://world2.test.svc.cluster.local:30002 works fine.
But as soon as i try to ping the maesh adress http://world2.test.maesh:30002 it wont work.

For reference its about this deployment Github

It just says ould not resolve host: world2.test.maesh with either curl or wget.

I installed Maesh in the namespace maesh and with helm3. As for the Controller Images i used latest and v1.1.

I tested this configuration on Azure and locally with KinD.

Also: i tried to set the Port on 80 for the service world 2 and still the host cannot be resolved if called with maesh.

Im not sure if j have just a small error or something but thanks in advance.


Further Tests have shown that my configuration works locally with KinD. But as soon as im working on azure the same configuration does not work anymore.
The host cannot be resolved.

Hello @kek112,

Have you solved your issue?

If not, we just released v1.2.
Can you try it to see if it solves your problem?

Hope this helps!