Unable to access Jaeger UI behind Traefik ingress

0

I have setup Jaeger as per the instructions from this post. I am unable to access the Jaeger UI in browser when I go to ( http://myhost.com/jaeger ). Instead of opening the dashboard the browser opens another website with domain myhost.com. I am attempting to open the dashboard from my PC on the corporate LAN.

Jaeger components are all setup :

ks -n monitoring get services
NAME               TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)                               AGE
jaeger-agent       ClusterIP   None             <none>        5775/UDP,6831/UDP,6832/UDP,5778/TCP   92m
jaeger-collector   ClusterIP   10.110.225.20    <none>        14267/TCP,14268/TCP,9411/TCP          92m
jaeger-query       ClusterIP   10.111.184.121   <none>        80/TCP                                92m
zipkin             ClusterIP   None             <none>        9411/TCP                              92m


 ks -n ingress-nginx get services
NAME                                 TYPE           CLUSTER-IP       EXTERNAL-IP    PORT(S)                      AGE
ingress-nginx-controller             LoadBalancer   10.111.102.209   17.168.1.181   80:32137/TCP,443:30505/TCP   4d9h
ingress-nginx-controller-admission   ClusterIP      10.111.197.68    <none>         443/TCP                      4d9h

And the hosts file :
image

Jaeger is setup on a k0s cluster (on a Debian 10 Buster instance).

My undersatnding is that the host/Traefik configuration should make the Jaeger UI accessible outside the cluster.

Ingress config is as follows:

apiVersion: networking.k8s.io/v1
kind: Ingress
metadata:
  annotations:
    kubernetes.io/ingress.class: traefik
    nginx.ingress.kubernetes.io/rewrite-target: /
    ingress.kubernetes.io/auth-type: basic
    ingress.kubernetes.io/auth-secret: my-auth-secret
  name: jaegerquery-ingress
  namespace: monitoring
spec:
  rules:
  - host: myhost.com
    http:
      paths:
      - path: /jaeger
        pathType: Prefix
        backend:
          service:
            name: jaeger-query
            port:
              number: 80

What am I missing ?