Unwanted URL manipulation

When using Traefik as proxy requests get manipulated in an unwanted way. This leads to errors with the site accessed. Can someone suggest whether this is a configuration problem or maybe a bug?

The working URL is this (site is accessed directly):
GET /fhem?XHR=1&inform=type=status;filter=WEB;since=1660663766.28339;fmt=JSON&fw_id=31648

When I request the same through Traefik as proxy the URL is changed to this:
GET /fhem?XHR=1&inform=type=status&filter=WEB&since=1660663582.13987&fmt=JSON&fw_id=31596

The ; are replaced by &.

This is my configuration in the compose file:

    image: traefik
    restart: always
      - --api.insecure=true
      - --entrypoints.websecure.address=:443
      - --providers.docker
      - --providers.docker.exposedByDefault=false
      - --providers.file.directory=/etc/traefik/dynamic_conf
      - "80:80"
      - "443:443"
      # The Web UI (enabled by --api.insecure=true)
      - "8085:8080"
      - /var/run/docker.sock:/var/run/docker.sock
      - ./reverseproxy/traefik.yml:/etc/traefik/dynamic_conf/conf.yml:ro
      - ./reverseproxy/cert.pem:/certs/cert.pem:ro
      - ./reverseproxy/key.pem:/certs/key.pem:ro

And these are the labels on the container that is accessed:

      - "traefik.http.routers.fhem.rule=PathPrefix(`/fhem`)"
      - "traefik.http.services.fhem.loadbalancer.server.port=8083"
      - "traefik.http.routers.fhem.entrypoints=websecure"
      - "traefik.http.routers.fhem.tls=true"
      - "traefik.enable=true"

Hi Cheanrod and welcome to the traefik forum.

This behavior started with version 2.7.2. There is an open issue on GitHub:


Hi wollomatic,

thanks for pointing me to the existing issue. I will follow the discussion there.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.