Issue with # in URL


im fresh on traefik, so please be patient if i dont understand your answears ;).
I am currently running ca. 5 containers with traefik. All works fine, but i have one cosmetic issue.
In every URL i have the format

Im running traefik with docker-compose (latest version of docker, and latest version of traefik image).
Im posting my label configuration, that i use to make the containers public:

      - "traefik.enable=true"
      - "traefik.http.routers.servicename.entrypoints=http"
      - "traefik.http.routers.servicename.rule=Host(`domainname`)"
      - "traefik.http.middlewares.servicename-https-redirect.redirectscheme.scheme=https"
      - "traefik.http.routers.servicename.middlewares=servicename-https-redirect"
      - "traefik.http.routers.servicename-secure.entrypoints=https"
      - "traefik.http.routers.servicename-secure.rule=Host(`domainname`)"
      - "traefik.http.routers.servicename-secure.tls=true"
      - "traefik.http.routers.servicename-secure.tls.certresolver=http"
      - "traefik.http.routers.servicename-secure.service=servicename"
      - ""
      - ""
       - default
       - proxy

If you need more information, just ask.
Thanks for reading, have a nice weekend :slight_smile:

Welcome @ClepToManix

I do not understand the issue. Could you please clarify?

Are you saying that your initial request does not include the # character?

Hallo @cakiwi,

thanks for ur fast reply.

Every requested domain is this format. For example (for Traefik Dashboard)
Or simply my bitwarden Container,

Best regards

Sorry @ClepToManix I'm still not understanding what your issue actually is.

Hello @cakiwi
Thanks for ur support.
I Jean the Hastag in every URL.
Normally it should have to be
But there is an Hashtag between. I will send you a Screenshot when im comming Home from work

Oh I see. That is entirely due to the web applications (javascript traefik dashboard and bitwarden) and nothing to do with traefik as an Edge Router. The fragment # is used by the browser and not sent as part of an http request.

If you setup another container this may or may not be present. Try a containous/whoami container for example.

Thank You!

I tried it with whoami container and it works. It seems to be, that all my containers use this.

Thanks for ur fast help :slight_smile:
Have a nice weekend :wink: