Traefik Dashboard Shows ""

Hi there.

I can't get access to Traefik Dashboard, no matter what I try...

System: openSUSE Tumbleweed (Bare Metal w/o Docker)
Version: 2.10.7
Go version: go1.21.5
Built: 2023-12-06T15:54:59Z
OS/Arch: linux/amd64

Installed from Repository or from precompiled Git binary leads to the same result.

Extract from my static conf:

  dashboard: true
  insecure: true (I tried false as well, same effect)

    address: ':80'
          to: https
          scheme: https
          permanent: true
    address: ':443'
    address: ':8080'

Extract from my dynamic conf:


        - "https"    
      rule: Host(``)
        - headers_sec
      service: api@internal
        certResolver: http

The result in my browser is always the same, no matter if I call the URL or by http://IP:8080:

Content of the file is

For more information see `webui/`

Does this mean that the webui is neither built in the openSUSE package nor in Git's precompiled binary? According to openSUSE Factory Build Logs the Webui should be included though...

Or did I miss something?

All working fine exept the dashboard.

Prevously I ran Trafik on Alpine and everything worked just fine.

Access Log:

 - - [04/Feb/2024:14:29:46 +0000] "GET /dashboard/ HTTP/2.0" 200 101 "-" "-" 83 "" "-" 15ms
 - - [04/Feb/2024:14:29:46 +0000] "GET /robots.txt HTTP/2.0" 404 19 "-" "-" 84 "" "-" 15ms
- - [04/Feb/2024:14:29:48 +0000] "GET /dashboard/ HTTP/2.0" 200 101 "-" "-" 89 "" "-" 15ms
 - - [04/Feb/2024:14:29:48 +0000] "GET /robots.txt HTTP/2.0" 404 19 "-" "-" 90 "traefik.mydomain.coml@file" "-" 15ms

Traefik Log:

time="2024-02-04T14:33:33Z" level=info msg="Traefik version dev built on I don't remember exactly"
time="2024-02-04T14:33:33Z" level=info msg="\nStats collection is disabled.\nHelp us improve Traefik by turning this feature on :)\nMore details on:\n"
time="2024-02-04T14:33:34Z" level=info msg="Starting provider aggregator aggregator.ProviderAggregator"
time="2024-02-04T14:33:34Z" level=info msg="Watchdog activated with timer duration 500ms"
time="2024-02-04T14:33:34Z" level=info msg="Starting provider *file.Provider"
time="2024-02-04T14:33:34Z" level=info msg="Starting provider *acme.Provider"
time="2024-02-04T14:33:34Z" level=info msg="Starting provider *traefik.Provider"
time="2024-02-04T14:33:34Z" level=info msg="Starting provider *acme.ChallengeTLSALPN"
time="2024-02-04T14:33:34Z" level=info msg="Testing certificate renew..." providerName=http.acme ACME CA=""

Thanks for your comments,

There is a big difference if you use insecure: trueor not. If enabled, Traefik dashboard will be available on port 8080 at path /dashboard/ on any "host" without a router. If disabled, you should see it at assigned entrypoint https port 443 with rule Host() and path /dashboard/. I don't see any certresolver in your config.

Share your full Traefik static and dynamic config, and docker-compose.yml if used.

Compare with simple Traefik example. Static config is in command, dynamic config is in labels.

Hi there,

thanks for your efforts.

I know. I tried all the variations. Same config actually DID work on another distro (Alpine 3.18) and it DOES work if I mount it to a Traefik Podman unit.

So my conclusion is that the openSUSE Factory Package and the precompiled binary on Github are not thouroughly compiled for version 2.10.7

Unfortunately I am only a user and not a developer and don't know how to compile from source myself.

For the moment I am helping me with Podman although I'd prefer it on bare metal.

If anyone has any further ideas or has an exhaustive instruction of how to compile Go packets on openSUSE: make me happy and teach me!


If you see this message is because your compiled version of Traefik can be "corrupted", and the webUI is missing inside the binary.

The prebuilt binaries inside this page have the WebUI.

If you want to compile your version, I recommend using the targets inside our Makefile and follow this documentation.

Hi Idez,

thanks. This helps me a lot. I thought I was stupid :wink:

I took the original binary from the official Github Repo:

and received the mentioned error.

I checked the checksum (SHA256, right?) now and it is not valid (should have done this before....).

Should I file an issue?

The checksum is right:

$ sha256sum traefik_v2.10.7_linux_amd64.tar.gz                                                                                               
c65813ad79ad8b719fbd2526f91098578849611d6ce1160260dd03bed1314d9a  traefik_v2.10.7_linux_amd64.tar.gz


c65813ad79ad8b719fbd2526f91098578849611d6ce1160260dd03bed1314d9a  traefik_v2.10.7_linux_amd64.tar.gz


...I just now downloaded it again from Git and get


for the linux amd64 binary...

I just clicked on this link, downloaded the archive and computed the checksum.

FYI GitHub is not Git.

I am using your link and I am getting




Wondering what is going wrong here?

Do you compute the sha256 on the archive or the executable?

the checksum is for the archive.


c65813ad79ad8b719fbd2526f91098578849611d6ce1160260dd03bed1314d9a  traefik_v2.10.7_linux_amd64.tar.gz
$ sha256sum traefik_v2.10.7_linux_amd64.tar.gz                                                                                               
c65813ad79ad8b719fbd2526f91098578849611d6ce1160260dd03bed1314d9a  traefik_v2.10.7_linux_amd64.tar.gz

$ sha256sum traefik                           
a3c4675c4285343290014dd402809de2de6e58c5f19f4be76210667e57658c9c  traefik

Got it. Sorry.

But nevertheless the "DONT-EDIT-FILES..." error is still there with this binary...

so the problem is not the binary but your configuration.

I recommend following this message Traefik Dashboard Shows "" - #2 by bluepuma77

I don't think so because as I said SAME config is running within Podman or on Debian or Alpine.

I am using openSUSE Tumbleweed.

Maybe something else is misconfigured within openSUSE. I'll check that out.

Anyway, thanks to the both of you, helped me to narrow down the caus.