Cannot access Dashboard

Hello,

i'am aware of several topics on github and here on how to expose the dashboard the secure way. I think i got it configured right, but it fails. Maybe i still miss something?

UPDATE1: splitted static/dynamic configuration now

STATIC: /etc/traefik/traefik/toml:

## see https://docs.traefik.io/reference/static-configuration/file/
[global]
  sendAnonymousUsage = false
  checkNewVersion = false

[log]
  level = "debug"
  filePath = "/var/log/traefik.log"

[accessLog]
  filePath = "/var/log/traefik.access.log"

[serversTransport]
  insecureSkipVerify = false
  [serversTransport.forwardingTimeouts]
    dialTimeout = "30s"
    responseHeaderTimeout = "0s"

[entryPoints]
  [entryPoints.http]
    address = ":8080"
    [entryPoints.http.transport]
    [entryPoints.http.transport.respondingTimeouts]
      readTimeout = "0s"
      writeTimeout = "0s"
      idleTimeout = "180s"

#########################  tls endpoint configuration ##########################
#########################  /tls endpoint configuration/ ##########################

#########################  admin backend configuration ##########################
  [entryPoints.api]
    address = ":8000"

[api]
  insecure = false
  dashboard = true
  debug = false

[ping]
  entryPoint = "api"

# The rest of the configuration for the dashboard can be found under
# /mnt/filestorage/default-admin-dashboard.toml since it is dynamic ( router )

#########################  /admin backend configuration/ ##########################

#########################  acme ###########################
#########################  /acme/ #########################
#########################  rancher fronend/backend defintions  ##########################
[providers]
#########################  /rancher fronend/backend defintions / ##########################
#########################  kubernetes fronend/backend defintions ##########################
#########################  /kubernetes fronend/backend defintions/ ##########################
#########################  file base fronend/backend defintions ##########################
  [providers.file]
    directory = "/mnt/filestorage"
    watch = true
#########################  /file base fronend/backend defintions/ ##########################
#########################  docker based fronend/backend defintions ##########################
  [providers.docker]
    endpoint = "unix:///var/run/docker.sock"
    defaultRule = "Host(`{{ normalize .Name }}.docker.lan`)"
    exposedByDefault = true
    swarmMode = false
    constraints = [  ]
#########################  /docker based fronend/backend defintions/ ##########################
#########################  metrics ##########################
#########################  /mentrics/ ##########################

And then in addition the DYNAMIC under /mnt/filestorage/default-admin-dashboard.toml

[http.routers.my-api]
  entryPoints = ["api"]
  rule = "PathPrefix(`/dashboard`) || PathPrefix(`/api`)"
  service = "api@internal"
  [http.routers.my-api.tls]
    options = "defaultTlsOptions"

I see this in the debug logs

traefik_1  | time="2019-12-07T15:13:27Z" level=warning msg="No domain found in rule PathPrefix(`/dashboard`) || PathPrefix(`/api`), the TLS options applied for this router will depend on the hostSNI of each request" entryPointName=traefik routerName=my-api@file

So i suggest the router is found and parsed ( this time )

I did mount the :8000 - 8000:8000 and try to access the dasboard either using http://localhost:8000 or http://localhost:8000/dashboard - but neither is working (404) - neither it works using wget localhost:8080/dashboard right in the container.

http://localhost:8000/ping works ( 200 ) - which is defined on the same endpoint

I'am running 2.0.6 as a docker image

Anything obvious i might miss?

Hello,

the entrypoint api is not defined in your configuration.

@ldez sorry i migrated from traefik to api during the course of the debugging here and forgot to update the toml paste here - i updated it now - both are exactly state of the art now.

http(s)://localhost:8000/dashboard is not working. Any other hints?

https://docs.traefik.io/v2.0/operations/dashboard/

The trailing slash / in /dashboard/ is mandatory

http(s)://localhost:8000/dashboard/

oh .. that's suprising . https://localhost:8000/dashboard/ is working now. Thank you!