Stripprefix and redirect

I've been trying to get traefik working in combination with opensearch on my docker swarm for a few days now and I'm hitting a wall.
I've got the following url which i can access to login to my opensearch webpage: 'hostname:5601' (which automaticly redirects to hostname:5601/app/login?)
The goal is to have an url like hostname/kibana which should be the same as hostname:5601
Some additional info: i'm not using a domain name, just the servername itself.

I used the same logic as I did on my whoami test case:

image: opensearchproject/opensearch-dashboards:2.0.1
container_name: opensearch-dashboards
- OPENSEARCH_HOSTS=["https://opensearch-node1:9200"]
- "traefik.enable=true"
- ""
- "traefik.domain=hostname_server"
- "traefik.http.routers.kibana-rtr.service=kibana-svc"
- "traefik.http.routers.kibana-rtr.entrypoints=http"
- ""
- "traefik.http.routers.kibana-rtr.rule= Host(hostname_server) && PathPrefix(/kibana)"
- "traefik.http.middlewares.kibana-rtr.stripprefix.prefixes=/kibana"
- "traefik.http.routers.kibana-rtr.middlewares=kibana-rtr@docker"
- "traefik.http.routers.kibana-rtr.middlewares=strip-kibana"
- "traefik.http.middlewares.strip-kibana.stripprefix.prefixes=kibana"
- proxy

this gives me as result

{"statusCode":401,"error":"Unauthorized","message":"Authentication required"}

Essentially what I think needs to happen is a redirect after the replacement of kibana vs the portnumber towards the rest of the path (being /app/login?)

Any hints in the right direction would be appreciated!