Not getting cert if tls certProvider is not specified

Is it just me or did I dream that you could avoid "tls: certProvider" when your endpoint is tls and also has a default cert provider assigned.

I have to go to each IngressRoute and add
certProvider: le
otherwise I don't get a cert assigned even if i have only one certificate resolver, which I assume 99.99% of users have.

Hello @mnorrsken

Yes, you have to specify the certificate provider on IngressRoute in order to get certificates. The attribute is mandatory - tls: turn on TLS termination and certProvider specify which provider you can use. Typically, you can create more than one certificate provider e.g. for staging and for the production environment.

Thank you,