How do I enable SNI?

I have Traefik set up as a docker container on my unraid server exposing some other docker containers via my domain. When I run browser test on CloudFlare, SNI shows as off. How do I enable SNI?

What do you want to achieve?

Traefik can read HostSNI from requests when Traefik received them with TLS, has TLS enabled and has access to the cert to decrypt the request.