Disable "TRAEFIK DEFAULT CERT" in k3s cluster

my-domain name : k3.tricogdev.net

when i do ssl check from :aboutssl. org , it says

  • k3.tricogdev.net resolves to 122.185.108.210

  • Server Type: nginx/1.21.5

  • The certificate was issued by TRAEFIK DEFAULT CERT .

  • The certificate will expire in 364 days.

  • The domain name does not match the certificate common name or SAN!

  • No Intermediate/Chain certificate were found.

  • k3.tricogdev.net resolves to 122.185.108.210

  • Server Type: nginx/1.21.5

  • The certificate was issued by TRAEFIK DEFAULT CERT .

  • The certificate will expire in 364 days.

  • The domain name does not match the certificate common name or SAN!

  • No Intermediate/Chain certificate were found.

My goal : how to completely disable/remove this certificate generated by TRAEFIK DEFAULT CERT
Ingress controller : traefik installed to my cluster by Helm (traefik-10.9.1)
My cluster : on top of bare metal
Kubernates : v1.21.7 by k3s rancher

Please help me.

1 Like

What would you expect to happen instead? Without a certificate no HTTPS request is possible. So you should either provide your own default cert or get Traefik (or cert-manager) to request a valid Let's Encrypt cert.

Here's how to provide a different default cert: TLS - Traefik | Site | v2.0