Can't connect to docker daemon (multiple tries on multiple env)

Hello all, so here is the deal I thought it would be a nice weekend project to setup traefik but it turned out to be the biggest nightmare in I have ever been in...

So here is my story:
I started on mac with docker desktop and I ended up having the phrase that now gives me PTSD:
"Cannot connect to docker daemon art unix:///var etc..."

I must say that this NEVER happened before things like portainer run just fine connecting to the daemon without any issue.
I created the docker group added my user tried again and same epic fail...
I was touching rock bottom

But I thought ok maybe it is a mac issue, let me boot up an ubuntu server instance to try and see things throught, and well guess what... SAME THING !!

So yeah I don't know what is happening but this makes me just want to ditch this product and stay with nginx and be happy and see the beauty in life again...

unless a charitable soul gives me a hand and helps me come back from the hell I've been in for the last three days...

Cheers and SOS


What exactly are you trying to do?
What's your configuration (files, docker-compose, ...) ?

You need to provide more information.

Hi ! thank you for taking the time to answer.

The docker environment is brand new just downloaded and no edit have been done.
Docker version is: 19.06.8

On that I added the docker group and added myself to it so I can run docker command as non root user.

The traefik docker compose is the one that can be found in the quick start guide here it is:

version: '3'

    # The official v2 Traefik docker image
    image: traefik:v2.2
    # Enables the web UI and tells Traefik to listen to docker
    command: --api.insecure=true --providers.docker
      # The HTTP port
      - "80:80"
      # The Web UI (enabled by --api.insecure=true)
      - "8080:8080"
      # So that Traefik can listen to the Docker events
      - /var/run/docker.sock:/var/run/docker.sock

And that is pretty much it, nothing else.
If i run that via

docker-compose up -d reverse-proxy

I just get the message I have been talking about earlier, in the log messages.

That's it nothing else is on that ubuntu server, it is clean.