Admin 8080 "connection refused"

Hey all!

Traefik newbie here. I've been trying to implement traefik on GKE, and I'm having a really hard time getting access to the api / dashboard.

I've configured the traefik.yaml file to include:

    insecure: true
    dashboard: true

But anytime I make a request to that port it fails with a "connection refused".

I've opened a shell into the container and tried curling localhost:8080 but get the same error.

There are no logs being generated (log level is set to DEBUG), except for 1:
accept tcp [::]:80: use of closed network connection" entryPointName=http

I'm able to call traefik on port 80 from in and out of the container and get a 404 not found (as expected).

I can only assume my config is wrong somehow and the API /dashboard isn't enabled, but can't see where i've gone wrong.

Any help would be really appreciated!

Got it working. I was accidentally mounting the config to /etc/traefik/config/traefik.yaml instead of /etc/traefik/traefik.yaml