VERY bad Upload Speed when using traefik with TSL / SSL

Few days ago i posted this for me keep getting same error everywhere i try, including a brand new cloud server from linode.

After spending few days on the problem, i solved it with the following config.

version: "3.9"
image: traefik:v2.8.0
container_name: traefik
- --log.level=INFO
- --api.insecure=true
- --providers.docker=true
- --providers.docker.exposedbydefault=false
- --entrypoints.web.address=:80
- --entrypoints.websecure.address=:443
- 5000:80
- 5001:443
- 8080:8080
- /var/run/docker.sock:/var/run/docker.sock:ro
image: openspeedtest/latest
container_name: speedtest-service
- "traefik.enable=true"
- "traefik.http.routers.openspeedtest.rule=Host("
- "traefik.http.routers.openspeedtest.entrypoints=web"
- "traefik.http.middlewares.limit.buffering.maxRequestBodyBytes=10000000000"
- "traefik.http.routers.openspeedtest.middlewares=limit"
- "traefik.http.routers.openspeedtest-https.rule=Host("
- "traefik.http.routers.openspeedtest-https.entrypoints=websecure"
# - "traefik.http.middlewares.limit.buffering.maxRequestBodyBytes=10000000000"
- "traefik.http.routers.openspeedtest-https.middlewares=limit"
- "traefik.http.routers.openspeedtest-https.tls=true"
- "traefik.http.routers.openspeedtest-https.tls.certresolver=leresolver"

with SSL for Traefik, i got 1.6Gbps for download and little over 1Gbps for upload.

Traefik did well on HTTP Test,

Docker image did well on HTTP and HTTPS when we use it without Traefik.

This is a configuration issue? or this is the default performance of Traefik when we enable TSL?

You can reproduce this issue on a raspberry pi, You will see with TSL OpenSpeedTest/Latest docker image will get 700Mbps speed and when it go behind traefik proxy the speed will be 200 to 300 Mbps. that is Close to 3 Times slower, if you run a 10Gbps speed test that is close to 10X slower. That means if you deployed traefik Infront of a large traffic website for some reason, suddenly you need 10X more hardware to serve same amount of people. Ether this is due to bad configuration or a bug in traefik.

""It appears as though the logic is wrong, downloading is swapped with upload""

This user encountered both issues reported here.