Unable to ping Synology from Traefik

I have had Traefik v2 running for a few days as a container service on my Synology NAS. It has been working perfectly fine and i can successfully browse to my other containerised, and non-containerised services (CCTV, Home Assistant etc) over the public internet via Traefik.

One thing I did notice that when enabling Access.log - it wouldn't show me the real IP of the originating client. Having read solutions online that I should put the Traefik ports in 'Host' mode - this still did not work for me - so I thought I'd create a macvlan network and have Traefik sitting on that network with it's own IP on my LAN. This has worked for me to an extent - I can browse to all but 1 of my services now. The one I can not access over the public internet is my Synology Host!

If I SSH into the Synology - I can ping the IP of my Traefik container fine.
If I SSH into the Traefik container - I can NOT ping the Synology however I can ping everything else on my LAN. I'm not sure what I'm doing wrong here.

The log entry shows: level=debug msg="'502 Bad Gateway' caused by: dial tcp connect: no route to host"

Here's a copy of my compose that stands up Traefik: version: "3.8"services:############ TRAEFIK ################ traefik: - Pastebin.com

Successful ping from Synology ( to Traefik (.29):

SSH into my Traefik container - unsuccessful ping to Synology (.113) but successful ping to my home router (.1)

Route print of my Synology NAS

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default RT-AC68U-5ED8.l UG 0 0 0 eth0 U 0 0 0 eth3 U 0 0 0 eth2 U 0 0 0 eth1 U 0 0 0 docker0 U 0 0 0 docker-54e435ae U 0 0 0 docker-4a7e0606 U 0 0 0 eth0 U 0 0 0 macvlan0

Habe you tried setting only required ports into host mode?


version: '3.9'

    image: traefik:v2.9
      # listen on host ports without ingress network (Docker Swarm)
      - target: 80
        published: 80
        protocol: tcp
        mode: host
      - target: 443
        published: 443
        protocol: tcp
        mode: host

If you have a Load Balancer in front of your setup, check Traefik ProxyProtocol.