Traefik see's local clients in network as remote

I have a proxy set-up for Plex and when I try to stream content inside my network, everything is by default transcoded because Plex thinks I am connecting as a remote client. Is there a header or some other setting that I need to add so that the real IP of the client is always detected?