Traefik route two entrypoints on same Hostname


I am using Docker Swarm to deploy a application stack and use traefik as reverse proxy for many services.
It's working well, however i'm stuck for my RabbitMQ service.

Here is the service config :

    image: Internal_IP:5000/rabbitmq
    hostname: rabbitmq-obmq
        - traefik.enable=true
        - traefik.http.routers.rabbitmq-obmq.rule=Host(`imsobmq02.rabbitmq.domain.local`)
        - traefik.http.routers.rabbitmq-obmq.entrypoints=rabbitmq
        - traefik.http.routers.rabbitmq-obmq.service=rabbitmq-obmq@docker
        - traefik.tcp.routers.rabbitmq-OBMq.rule=HostSNI(`imsobmq02.rabbitmq.domain.local`)
        - traefik.tcp.routers.rabbitmq-OBMq.entrypoints=rabbitmq-int
        - traefik.tcp.routers.rabbitmq-OBMq.service=rabbitmq-OBMq@docker
      - "5672"
      - "15672"

The HTTP labels works well, RabbitMQ management console is reachable from outside, but it doesn't work for the TCP ones.

I don't understand what is wrong on my set up.

Someone could help me ?


I'm not 100% sure but the http service name and the tcp service name are the same(ignoring case).
Try changing the name on this line


I just tried but still the same
My rabbitmq consumer wont connect while if I set up the rabbitmq docker service name instead, it is working.
Is that possible to log TCP requests on Traefik ?