TLS minVersion: VersionTLS10 has no effect

As default on traefik 2 (v2.1.2) there is TLS1.2 enabled.
As i need tls1.0 for the moment, i tried to overwrite it with the following dynamic config:

# Dynamic configuration
      minVersion: VersionTLS10

but even if i restart traefik with this, tls1.0 is not enabled

is there something i forgot to change?

On v2.1.3 using TLS defaults I can connect using TLSv1, TLSv1_1, TLSv1_2 and TLSv1_3.

How are you testing? curl --tlsv1.0 for my test did not work. openssl s_client --tlsv1 and sslyze --tlsv1 worked.

I've run an ssl Labs test.

Weird. I just did one on v2.0.5 tls options are default . TLS v1.0 thru 1.3 are all connecting.

Are you doing anything else with tls options like defining ciphers or using an elliptic curve key or ... anything?

There were some cipher definitions, but i disabled them to test the TLS Version.
Maybe its a problem from later Versions? I'm on 2.1.2

Could you provide all your configuration (static and dynamic file, docker-compose file, etc.)

From my earlier post it works on 2.1.3, and my later post 2.0.5.

The 2.1.3 version I later used minVersion and ciphers to prepare for tls1 - tls1.1 deprecation and ciphers to only provide PFS. Before that it was a solid B on Ssllabs.

Best of luck.

I've retested and now it works. thank you alot.
I've found the problem.
I set TLS1.2 Ciphers in tls.default option, and tried to downgrade tls version with another option, but I've not set ciphers matching the tls version there.
so it used the ciphers from the default option i think. and so tls1.0 and 1.1 was not working.

thank you again for the help.

Can you provide all of the configuration files? I'll be very grateful for this favor.
Regards: Home Addition Agoura Hills.