Second http route keeps restarting

Hello everyone!
I am trying to use traefik as a learning experience for Docker. so far I'm really liking it and its really helped me understand a lot of concepts. my project is to use traefik on my raspberry pi to host two websites at the same time. I started with the basic guide in the documentation and was successfully able to add my first container and get it running. after a quick stack overflow post I added the domain to my hosts file and was able to access my website through traefik!

Today I though I would try to tackle adding the second website. I copied the section I had for my first website and edited the parts I had changed from the guide. I also added the second domain to my hosts file exactly like the first one.
But when running docker-compose up the container seemed to have started perfectly fine but I haven't been able to access the website. docker ps shows it as running. but when going to traefik dashboard the route and service seemingly just appear and disappear in a rapid 10-20 second cycle.
Going to the second webpage i either get a "bad gateway" or "404".
I can still access the first website perfectly alright.

here is what i have for my docker-compose.yml

version: "3.3"


image: "traefik:v2.2"
container_name: "traefik"
- "--log.level=DEBUG"
- "--api.insecure=true"
- "--providers.docker=true"
- "--providers.docker.exposedbydefault=false"
- "--entrypoints.web.address=:80"
- "80:80"
- "8080:8080"
- "/var/run/docker.sock:/var/run/docker.sock:ro"
restart: always

image: "wolfexe57/furriesyelling:1.1"
# container_name: "FY-website"
- "traefik.enable=true"
- "traefik.http.routers.furriesyelling.rule=Host("
- "traefik.http.routers.furriesyelling.entrypoints=web"
restart: always

image: "wolfexe57/website-html-docker:latest"
# container_name: "TM-website"
- "traefik.enable=true"
- "traefik.http.routers.toddmcintire.rule=Host("
- "traefik.http.routers.toddmcintire.entrypoints=web"
restart: always

EDIT: I can see via docker PS that it will restart about a second or two after starting.
I also tried setting the ports for the second website but they seem to remain at 80

Ok so I solved this and the error was something I haven't even considered in the logs.
The reason it was restarting constantly was because the container wasnt properly working in the first place. after running docker ps and copying one of the restarted containers id's I was able to use docker logs to get the error "standard_init_linux.go:211: exec user process caused "exec format error"
The docker hub build setting is set for 64bit which my raspberry pi isint, its arm. So I just had to quickly build the container on my raspberry pi with the tag and it works!