Media query prefers-color-scheme not working

Hello everyone,

Some of the services that I use support the CSS media query for color schemes (prefers-color-scheme). When I navigate to them directly using the ip and port, that query gives the correct output. However when I navigate to them through Traefik, it no longer does.

I read that those client hints work using an header names Accept-CH, so I've tried using middleware to set that header to the value that should allow the query to work, but it still doesn't. Anyone know more about this?

Thanks in advance

Why should Traefik change (remove) request or response headers without being instructed to do so?

Enable Traefik access log in JSON format and let it include all headers.

And share your Traefik static and dynamic config.

Seems that I was wrong on what the culprit is. After doing some more tests by accessing Traefik directly internally I found out that it is actually being caused by my network somewhere. The moment I use my public ip and thus enter through my router, it stops working.

Thanks for having my realize that Traefik has no reason too interfere (neither has my router by default though ...).

Using Docker Swarm and VLAN/vSwitch/VPN? Then you might want to check MTU.