Load Balancer requests in https

Hi!

I have been trying for a few days to configure traefik to access local url requests in https, this is my current configuration in http:

This is my config in dynamic-conf.toml

[http.routers]

[http.routers.r-plex]
   entrypoints = ["web"]
   rule = "Host(`plex.domain.com`)"
   middlewares = ["securityHeader","redirect-https"]
   service = "plex-app"

[http.routers.rssl-plex]
   entrypoints = ["web-secure"]
   rule = "Host(`plex.domain.com`)"
   service = "plex-app"   
   middlewares = ["securityHeader"]
[http.routers.rssl-plex.tls]
   certResolver = "myresolver"


[http.services]
[[http.services.plex-app.loadBalancer.servers]]
   url = "http://192.168.1.99:32900"

┬┐How can I redirect or pass the traffic from a local url with https in loadbalancer -> https://192.168.1.99:32900 directly without having to put the port 32900 in the url and be able to directly access https://plex.domain.com?
If I put this url https://192.168.1.99:32900 with https, it gives me an internal error and does not load me

Thanks

Someone would know the answer to solve my question?
Thanks

This little test worked fine for me:

docker-compose.yaml
version: "3.8"

services:
  traefik:
    image: "traefik:v2.5"
    command:
    - --entrypoints.web.address=:80
    - --entrypoints.web.http.redirections.entrypoint.to=websecure
    - --entrypoints.web.http.redirections.entrypoint.permanent=true
    - --entrypoints.websecure.address=:443
    - --entrypoints.websecure.http.tls=true
    - --providers.docker=true
    - --providers.docker.exposedbydefault=false
    - --providers.file.filename=dynamic.yaml
    - --accesslog
    - --accesslog.format=json
    - --api
    - --log.level=WARNING
    - --log.format=json
    labels:
      traefik.enable: "true"
      traefik.http.routers.api.rule: Host(`traefik.localhost`)
      traefik.http.routers.api.service: api@internal
    ports:
      - published: 80
        target: 80
      - published: 443
        target: 443
    volumes:
      - "/var/run/docker.sock:/var/run/docker.sock:ro"
      - "./dynamic.yaml:/dynamic.yaml"
dynamic.yaml
http:
  routers:
    appliance:
      rule: Host(`plex.localhost`)
      service: plex
  services:
    plex:
      loadBalancer:
        passHostHeader: false
        servers:
          - url: http://192.168.1.7:32400