K8s Traefik 404 Not Found all routes, logs show "Skipping Kubernetes event kind..."

I am trying to test a basic whoami website using Traefik as my ingress handler in Kubernetes. TLS with Let's Encrypt works, but I get a 404 for all routes (on https with green lock), and the logs say:

time="2020-07-10T09:32:27Z" level=debug msg="Skipping Kubernetes event kind *v1.Service" providerName=kubernetes
time="2020-07-10T09:32:27Z" level=debug msg="Skipping Kubernetes event kind *v1.Endpoints" providerName=kubernetes

In order to setup Traefik and the whoami container, I apply the following YAML in order:

1 - The Traefik custom CRDs: (link below)

2 - the ClusterRole and Service Account creation: (link below)

3 - The settings and dynamic provider settings in a ConfigMap: (link below)

4 - The deployment and associated loadbalance service: (link below)

5 - The whoami app deployment and ClusterIP service: (link below)

6 - The middleware and IngressRoute for the whoami service: (link below)

At this point, Traefik seems to work and I can connect to the url with https, but I get the 404 page and none of the middleware headers are present. Clearly Traefik is getting the incoming connection, but it's not routing the request. But I'm not clear why.

(I'm doing everything in the default namespace intentionally, just as a learning exercise.)

If somebody can tell me why the request isn't routed, I'd be very grateful!


The forums blocked me from putting more than 4 links in a post, so here's the first three, and the next reply will have the last three.

1 - https://s.maxweiss.io/9fflk

2 - https://s.maxweiss.io/BF8Op

3 - https://s.maxweiss.io/xzoMd

(4, 5, and 6 below)

4 - https://s.maxweiss.io/JWBrT

5 - https://s.maxweiss.io/g0MZO

6 - https://s.maxweiss.io/LjuuQ


I think I have the same issue, have you tried to access one of the sites with [CTRL]+[SHIFT]+[R]. it does work for me but only for the website you're using then to go to another website you need to do it again. But it after this the first website start to answer 404 again

Let me know

I definitely tried several hard refreshes, and I got nothing but 404s every time. I even swapped out whoami with a basic python script to just listen for http connections and output any time it was connected to, and it showed nothing. Traefik was just not routing anything.

Ok it seems it's a bug in 2.2.2 I have I have used the version 2.2.1 and it fixed my issue, I will open a bug report to see

I just tried it with v2.2.1 and had exactly the same behavior. I think whatever is happening with my setup is different from the intermittent bug others seem to be experiencing.

Thank you for the suggestion though, I do appreciate it.

Additional discussion happening in the reddit thread:

Just updating to say I solved the issue. I was using the incorrect provider "kubernetesIngress" instead of the correct provider of "kubernetescrd".