Idle Timeout Settings Rancher

I have Traefik v1.6 running in a Rancher cluster and can't seem to find out why the connection to my backend is being closed after 5 minutes of being idle (it is a service that is calling a long running stored procedure which I know isn't ideal in terms of design but that's what I've got to live with). The backend service does run to completion but the connection is dropped after 5 minutes. If I run the container locally and call it directly, the connection stays up until completion and so my belief is that traefik is dropping the connection to the backend. Since the default idle timeout is 3 minutes then I can't work out why it is being dropped after 5 minutes - I've tried changing the config both in the Rancher labels and in the environment variables of the Traefik containers but to no avail. I'm assuming there is no reason why I can't set the idle timeouts to be as long as I want so long as I'm happy to put up with the risk of running out of connections.

Hello @ScottMathieson,

did you check the Timeouts in your traefik.toml, as mentioned here?

HI @SantoDE,

The default settings are in place so I would have expected given the read/write timeouts are set to 0 that we wouldn't be seeing any disconnections. I was wondering if there was something in the underlying oxy implementation that has default timeouts or even at the net/http library level although nothing jumps out from looking at the source code to indicate any potential default timeout settings.