HTTP Routers with RedirectScheme failing with 400's

Hello! I've been using Traefik 2 for awhile now and I've had a config with the Kubernetes CRD provider working but last night when I tried enabling a secure dashboard all of my HTTP traffic over port 80 (all using a RedirectScheme to HTTPS) started failing with "400 Bad Request". I've been trying to troubleshoot where it's coming from but even with the Traefik log level set to DEBUG I don't see any logs for the requests that are failing (traefik, access or otherwise). My HTTPS traffic still works fine, I just can't seem to get the HTTP traffic redirects working any more.

The biggest change I made was adding a file provider in addition to my kubernetes crd provider in order to set up the dashboard router. I added a new http.middlewares and http.routers section to the file provider (some with the same name as on the kubernetes crd side, such as "force-tls" for the scheme redirect). I originally tried to use the middlewares defined in the file provider in my CRDs but it looks like those might not be shared across providers? I also tried setting up an IngressRoute CRD for "api@internal" but the docs say you can't do that because there's no service with that name (I feel like you should special case that so I'm not required to make a file provider).

Is there anything I should look at to help with troubleshooting this? I'm at a loss, it looks like everything is fine according to the logs and the dashboard.