Docker Swarm Mode: Minimum TLS Version not getting applied


I'm currently experiencing some issues withTraefik v1.7 using Docker Swarm.
I am unable to change the minimum TLS version to 1.3.
I have read the documentation and applied the configurations as mentioned.

Below is my TOML file that is loaded into the container using Docker configurations:

debug = true

logLevel = "INFO"
defaultEntryPoints = ["https","http"]

rootCAs = [ "/xxxx.pem", "/xxxxRootCA.pem" ]


    minVersion = "VersionTLS13"
  address = ":8080"
  address = ":80"
    entryPoint = "https"
  address = ":443"
    minVersion = "VersionTLS13"
      certFile = "/run/secrets/cert_secret"
      keyFile = "/run/secrets/cert_key_secret"

  entrypoint = "api"


endpoint = "unix:///var/run/docker.sock"
watch = true
exposedByDefault = false
swarmMode = true

In the TOML file above I am tring to force the TLS connection to use the version 1.3 (latest), but when I go into chrome devtools, in the security tab, I am able to see that the connection is still being established using TLS 1.2.
In local development, not using Docker swarm (using compose file and similar toml file for configuration), I am able to get all the connections to use TLS 1.3.

In my compose file I am also setting GO's enviroment variable:


Since that I am able to get the minimum TLS version applied in local development (not using swarm), and am not able to get the exact same configuration using swarm, does anyone have any ideas what could be going wrong here?