Docker Filtering disabled container v2.0.0-rc2

Hi, im currently setting up Traefik v2 with a new Docker Swarm Server.

Exprected Result:
Read Docker Labels and add the Service / Router.

Instead Happend:
Traefik does not detect Labels from other Containers. They are completly ignored.

time="2019-09-13T18:49:33Z" level=debug msg="Filtering disabled container" providerName=docker container=traefik_traefik-h1erzxp9upg87y4b8hmaghk24


time="2019-09-13T18:49:33Z" level=debug msg="Filtering disabled container" providerName=docker container=portainer_agent-i8wfq68bojikeiyahjsqkkpi5


time="2019-09-13T18:49:33Z" level=debug msg="Filtering disabled container" providerName=docker container=livezilla_webserver-4uep1os1u5njyh2qy2vova7c1


time="2019-09-13T18:49:33Z" level=debug msg="Filtering disabled container" container=portainer_portainer-uit96ksir1q0wp8tnkykwahlw providerName=docker


time="2019-09-13T18:49:33Z" level=debug msg="Configuration received from provider docker: {\"http\":{},\"tcp\":{}}" providerName=docker


time="2019-09-13T18:49:33Z" level=info msg="Skipping same configuration for provider docker" providerName=docker

My Service:

version: "3.7"
services:
  webserver:
    image: nginx:latest
    expose:
      - "80"
    networks:
      - reverse_proxy
    labels:
      - "traefik.enable=true"
      - "traefik.http.routers.webserver.rule=Host(`support.kdcp.de`)"
      - "traefik.http.routers.webserver.entrypoints=web,websecure"
      - "traefik.http.routers.webserver.service=webserver_livezilla"
      - "traefik.http.services.webserver_livezilla.loadbalancer.server.port=80"
networks:
  reverse_proxy:
    external: true

My Traefik Config:

version: "3.7"
services:
  traefik:
    image: traefik:2.0.0-rc1
    ports:
      - "80:80"
      - "443:443"
      - "8080:8080"
    networks:
      - reverse_proxy
    command:
      - "--log.level=DEBUG"
      - "--api=true"
      - "--providers.docker=true"
      - "--providers.docker.swarmMode=true"
      - "--providers.docker.exposedbydefault=false"
      - "--providers.docker.network=reverse_proxy"
      - "--providers.docker.endpoint=unix:///var/run/docker.sock"
      - "--entrypoints.websecure.address=:443"
      - "--entrypoints.web.address=:80"
      - "--global.sendAnonymousUsage=true"
      - "--certificatesresolvers.mytlschallenge.acme.tlschallenge=true"
      - "--certificatesresolvers.mytlschallenge.acme.email=******@replaced.***"
      - "--certificatesresolvers.mytlschallenge.acme.storage=export/acme.json"
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - data:/export
      
networks:
  reverse_proxy:
    external: true
      
volumes:
  data:

As it appears im just too stupid to operate docker swarm. Labels must be placed under the deploy tag.
#resolved

Hello, how do you fix this ?

I have log of "level=info msg="Skipping same configuration for provider docker" providerName=docker"

Thank you

Please check if your labels are placed below the deploy tag:

e.G. NOT
services:
--mygreatwebserver:
----labels:
------"traefik.http...."

Instead use this
services:
--mygreatwebserver:
----deploy:
------labels:
-------- - "traefik.http...."