Disable https redirection for a single container

Hi, currently i have https redirection enabled for all my containers as the default, but now i have a single web service that breaks when https is used. How i can disable the redirection for that service?

I tried using the following labels but still redirects to https.

 - "traefik.enable=true"
 - "traefik.port=80"
 - "traefik.docker.network=gateway"
 - "traefik.frontend.rule=Host:test.example.com"
# adding this didn't work
 - "traefik.frontend.entryPoints=http"

Default config:

defaultEntryPoints = ["http", "https"]

  address = ":80"
    entryPoint = "https"
  address = ":443"
      certFile = "/certs/example.com/cert.pem"
      keyFile = "/certs/example.com/key.pem"

endpoint = "unix:///var/run/docker.sock"
domain = "example.com"
watch = true
exposedByDefault = false
swarmMode = true
network = "gateway"

Hello @codestation,

Unfortunately there is no way to override entrypoint redirection in Traefik v1, as it is part of the static configuration that is loaded on startup.

You would have to disable the entrypoint redirect, and add the redirection on your other containers to accomplish what you are asking.

@daniel.tomcej Do you know if the upcoming v2 will support this? For now i will move this service outside the swarm as it will take too long to reconfigure all the other containers to accommodate this one.

Thanks for the help.

Traefik v2 does not have entrypoint redirection, it is configured per-router, so this issue does not apply to v2.