Can't connect to whoami from documentation

Hello, this is my first time trying Traefik.

From the documentation I did the stand-alone, went to Traefik hub, and followed the instructions for the agent. All I did was copy the docker compose yaml file and toss it into portainer.

version: "3.9"

services:
  # Start the agent with the latest version
  hub-agent:
    image: ghcr.io/traefik/hub-agent-traefik:v1.0.0
    pull_policy: always
    container_name: hub-agent
    restart: "on-failure"
    command:
      - run
      - --hub.token=TOKEN WAS ADDED HERE
      - --auth-server.advertise-url=http://hub-agent
      - --traefik.host=traefik
      - --traefik.tls.insecure=true
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
    depends_on:
      - traefik

  # Start Traefik with the latest version
  traefik:
    image: traefik:v2.8
    container_name: traefik
    command:
      # Enable Hub communication (open the port 9900 and 9901 by default)
      - --experimental.hub=true
      - --hub.tls.insecure=true
      - --metrics.prometheus.addrouterslabels=true

From there, for whoami, I ran from the documentation:

docker run -d -p 8080:80 --name whoami traefik/whoami

Had to add whoami container to the traefik network. Then I went back to hub, published it on port 80, and got the provided URL. From what I've read and watched, the site should be available now from the URL.

But the link doesn't work. The site says "If you’ve reached this page, either you’re lost or Hub is connecting your services to its final destination. Please try again in a moment.". I can only reach the site by using port 8080 on localhost and I just get plain text back.

I've tried rebuilding a few times manually and even changed the yaml to get the latest versions. Not sure what the issue is.

if you check docker logs hub-agent

do you see this message: "message":"unable to get IP"} ?

Yes! It starts doing this before I create the whoami container.

Can you paste here your hug-agent container log?

So I don't have those logs unfortunately but that was the error.

I rebuilt everything and here is the new error which looks similar.

2022/12/05 04:59PM INF version=v1.0.0 module=github.com/traefik/hub-agent-traefik commit=e32cae4 built=2022-10-26_09:54:23AM go_version=go1.19.2 os=linux arch=amd64
2022/12/05 04:59PM INF Using Agent reachable address | addr=http://hub-agent
2022/12/05 04:59PM INF Starting auth server | addr=0.0.0.0:80
2022/12/05 05:09PM WRN check new version | error=you are using v1.0.0 version of the agent, please consider upgrading to v1.0.1
2022/12/05 05:10PM ERR unable to get IP | workspace_id=638c3297b71d0d9d8267b4eb cluster_id=139d7686-24fb-4798-8942-9a472aa2e50d edge_ingress_id=638e6c437a6975170fbb295c service_name=whoami service_network= error=: no IP address

It is exactly what is happening to me.

I tried to downgrade traefik and hub-agent, I tried to others servers I still don't figure out what is happening.

Hello @gpnunes @Dekubaka, thanks for the report.
There is indeed a problem on our side that we are currently fixing.

2 Likes

it will be fixed with a update on client or server side? Will I need to update my docker images ?

You will probably not have to update your agent, simply re-publishing your service should suffice.
We are working on the issue and we will inform you as soon as a fix is deployed.

2 Likes

Any update on this or the cause of the issue?

1 Like

Any update on this or the cause of the issue again? I just wanted to test the platform but has this been happening to paid customers as well? Have they been unable to create with docker for the last 11 days?

1 Like

Hey all, same happening for me, I read all the docs and I was wondering if I'm missing something, glad to see others face the same issue... Any solutions / news appreciated.

Hello, sorry for the delay.
The correction has been deployed :slight_smile: .
You can test it right now by exposing a service.
Do not hesitate to come back to us if there is a problem.

1 Like

It's working for me, thanks for the help! Good job!
ps. Happy Holidays!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.