Can't Access Dashboard After Installing with Helm on Kubernetes

I have installed Traefik on my microk8s cluster using helm using the following commands:

helm repo add traefik
helm repo update
helm install traefik traefik/traefik \
  --namespace traefik \
  --create-namespace \
  --set logs.general.level="DEBUG"

That seems to install correctly, and after doing so I see the following:

# kubectl get all -n traefik
AME                                   READY   STATUS             RESTARTS   AGE
pod/traefik-ingress-controller-9tbhl   1/1     Running            0          29h
pod/traefik-5cd9d75d97-xh486           1/1     Running   0          17m
NAME                              TYPE           CLUSTER-IP       EXTERNAL-IP   PORT(S)                
service/traefik-ingress-service   NodePort     <none>        8080:32269/TCP         
service/traefik-web-ui            ClusterIP   <none>        8080/TCP               
service/traefik                   LoadBalancer    80:32625/TCP,443:31724/
TCP   29h

NAME                                        DESIRED   CURRENT   READY   UP-TO-DATE   AVAILABLE   NODE S
daemonset.apps/traefik-ingress-controller   1         1         1       1            1           <none>

NAME                      READY   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/traefik   0/1     1            0           29h

NAME                                 DESIRED   CURRENT   READY   AGE
replicaset.apps/traefik-5cd9d75d97   1         1         0       17m

I would like to be able to access the dashboard app using the kubectl port-forward command from the Traefik Helm Chart. However, I get a 404 when I try this because I don't seem to have any apps listening on port 9000.

Is there a step that I'm missing to "turn on" the dashboard when installing via the Helm chart? If not then which of the services listed above should I try and use for the dashboard? I've tried the traefik-web-ui and traefik services but still get 404's.

Of course, as soon as I post this I fix the problem :slight_smile:. I don't know why this didn't work before, but first I got the pod name like this:

kubectl get pods -n traefik

I then looked at the config for the traefik pod like this:

 describe pod traefik-97888b74d-gmdg9 -n traefik

When I did that I saw that it was listening on port 9000, so then I forwarded it like this:

port-forward traefik-97888b74d-gmdg9 9000:9000 -n traefik

...and then visited this URL:

I'm still not quite sure why the officially documented process didn't work before, but this solved my problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.