Cannot access Container from inside of my Network

Hello guys,

i have little Problem with my Traefik Setup since a few Days.

I set up a Raspberry 4, Docker, Portainer, Traefik, Home Assistand and a Nextcloud.
Everything worked well, I could acces my Home Assistant from inside and outside of my Network.

After a few Days I decided to change from a SD Card to an SSD.
The SSD also worked well for a few Days till I screwd it up.

So I switched back to the SD Card to clone it again to the SSD.

Since then I could access the Containers only from Outside of my Network.
When I try to access the Container from Inside I get a Connection Timeout.

I activated the debug log and the acces log.
There are no entrys when I try to access from inside.

I can't imagine what have changed that inside connection no longer works.

Do you have any Ideas what the Problem could be?

How did you start Traefik? Did you use absolute or relative file paths? You should be able to enable Traefik debug log. If it doesn't work, I would say your config is not loaded, probably because of a wrong path.

I used absolute paths.

I had the debug log enabled. It had also Entrys from the external attemps but not for the internal ones.

But in the meantime I found the Problem. It was the LAN Cable / Connection...
I disconnected the Cable and it worked. Before restoring the Backup, the Cable was also connected. I don't know why it was a Problem this time.