404 page not found on everything including dashboard through port forward (k8s helm)


i'm trying to get traefik 2.4.8 through the official helm chart up and running through a nodePort (which is used by an external LB).

But everything i try, i only get a 404 page not found back.

I have seen a few other threads but besides apiinsecure i haven't found any suggestion on a way for me to debug this further.

I assumed and played around with the service and nodeport but the dashboard is enabled but also returns a 404. At least trying the dashboard through kubectl should just work?

I checked out your workshop @jakubhajek but i did not find something invalid;

What would be my next steps for analysis?

My traefik logs set to DEBUG don't show any issue per se:

level=debug msg="Creating middleware" entryPointName=web middlewareName=traefik-internal-recovery middlewareType=Recovery


time="2021-05-31T18:35:42Z" level=debug msg="No default certificate, generating one"


time="2021-05-31T18:35:42Z" level=debug msg="No default certificate, generating one"


time="2021-05-31T18:35:44Z" level=debug msg="Skipping Kubernetes event kind *v1.Endpoints" providerName=kubernetescrd


time="2021-05-31T18:35:44Z" level=debug msg="Skipping Kubernetes event kind *v1.Endpoints" providerName=kubernetescrd


time="2021-05-31T18:35:44Z" level=debug msg="Skipping Kubernetes event kind *v1.Endpoints" providerName=kubernetes


Hello @Sicaine

Would you please share what has been configured in the values.yaml file?

Thank you,


I use it as a helm in helm chart:

    replicas: 1
#    kind: DaemonSet

# disabled until openebs
      load-balancer.hetzner.cloud/location: fsn1
      load-balancer.hetzner.cloud/network-zone: fsn1-dc14
    type: NodePort
      nodePort: 31080
      nodePort: 31443
    # Traefik logs concern everything that happens to Traefik itself (startup, configuration, events, shutdown, and so on).
      # By default, the logs use a text format (common), but you can
      # also ask for the json format in the format option
      # format: json
      # By default, the level is set to ERROR. Alternative logging levels are DEBUG, PANIC, FATAL, ERROR, WARN, and INFO.
      level: DEBUG
      enabled: true
    - "--certificatesresolvers.letsencrypt.acme.email=<Removed>"
    - "--certificatesresolvers.letsencrypt.acme.caserver=https://acme-staging-v02.api.letsencrypt.org/directory"
    - "--certificatesResolvers.letsencrypt.acme.tlschallenge=true"
    - "--certificatesresolvers.letsencrypt.acme.storage=/data/acme.json"
    - "--global.checknewversion"
    enabled: true
    name: data
    #  existingClaim: ""
    accessMode: ReadWriteOnce
    size: 128Mi
    storageClass: "openebs-hostpath"
    path: /data
    annotations: { }
    # subPath: "" # only mount a subpath of the Volume into the pod
    #    - "--certificatesresolvers.letsencrypt.acme.caserver=https://acme-v02.api.letsencrypt.org/directory"

hello @Sicaine

The configuration seems to be fine. Have you tried to use port-forwarding to access the dashboard. Traefik Helm Chart creates routing (ingressroute crd) for the dashboard, so you should be able to access it using the following command:

kubectl port-forward $(kubectl get pods --selector "app.kubernetes.io/name=traefik" --output=name) 9000:9000

Please make sure that the context is set to the namespace where you deployed Traefik.

Hey @jakubhajek ,

yep! Port-forwarding also doesn't work for me.

Does that mean that the routing itself is broken even when i try to do a port-forward directly on/to a pod?


Hi @Sicaine

What error logs you are getting once you execute port-forward command ?

Are there any error logs in Traefik ?

Please note that port-forwarding command should use namespace where Traefik pod is deployed, so maybe you should add -n or --namespace to the command, see the example:

kubectl port-forward --namespace default \
$(kubectl get pods \
--selector "app.kubernetes.io/name=traefik" \
--output=name \
--namespace default) \

Hope that helps.

Hi @jakubhajek ,

unfortunate i don't get any error logs but i did set it to the highest level possible.

The port forward itself just works, no issues, i still get a 404 which irritates me as i would assume that the dashboard should just work then.

Hey @sarke

Do you see anything in the logs when Traefik is starting?

Sry i gave up and switched to nexus.

I did not see any issues on traefik logs.