2.2 can't see Kubernetes defined entryPoint middlewares?

Hey everyone, I'm trying to configure an entrypoint level middleware to be run before all requests. I'm running on Kubernetes using v2.2.

Applicable part of my toml file:

    address = ":6443"
      middlewares = ["forward-auth"]

Traefik runs in the namespace traefik and I have the middleware forward-auth also in the same namespace.

When I try to run with this configuration I see the message: middleware "forward-auth@kubernetes" does not exist

The dashboard shows the middleware as existing as traefik-forward-auth@kubernetescrd which I've also tried with the same result.

I've tried the following values for middlewares and I'm stumped:

  • forward-auth@file
  • forward-auth@kubernetes
  • forward-auth@kubernetescrd
  • traefik-forward-auth@...
  • default-forward-auth@...

In case it's applicable here's the middleware manifest:

apiVersion: traefik.containo.us/v1alpha1
kind: Middleware
  name: forward-auth
  namespace: traefik
    address: http://auth-svc
      - X-Forwarded-User

Any insights are greatly appreciated.