# Websocket "'502 Bad Gateway' caused by: dial tcp connect: connection refused"

**URL:** https://community.traefik.io/t/websocket-502-bad-gateway-caused-by-dial-tcp-connect-connection-refused/9465
**Category:** Traefik v2
**Tags:** docker
**Created:** [January 27, 2021, 10:15am UTC](https://community.traefik.io/t/websocket-502-bad-gateway-caused-by-dial-tcp-connect-connection-refused/9465 "2021-01-27T10:15:48Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![cakiwi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/cakiwi/32/3205_2.png) [@cakiwi](https://community.traefik.io/u/cakiwi)
#### Post date: [January 27, 2021, 4:37pm UTC](https://community.traefik.io/t/websocket-502-bad-gateway-caused-by-dial-tcp-connect-connection-refused/9465/4 "2021-01-27T16:37:03Z")

</div>

> [@haikalrios](#):
>
> `dial tcp 172.19.0.3:4441: connect: connection refused`

This says the connection is being actively refused. Does this server required extra configuration. Is it actually bound on the referenced ip address. Does it have its own logs to see what happens to the connection.

Standalone is it using https? You service url is plain http.

---

_[View the full topic](https://community.traefik.io/t/websocket-502-bad-gateway-caused-by-dial-tcp-connect-connection-refused/9465)._
