# Traefik2.4: uses a non-existent resolver: inwx

**URL:** <https://community.traefik.io/t/traefik2-4-uses-a-non-existent-resolver-inwx/11283>\
**Category:** Traefik v2\
**Tags:** kubernetes-crd, cli, kubernetes-ingress, docker, letsencrypt-acme\
**Created:** [July 23, 2021, 10:06am UTC](https://community.traefik.io/t/traefik2-4-uses-a-non-existent-resolver-inwx/11283 "2021-07-23T10:06:41Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![flweber](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/flweber/32/4045_2.png) [@flweber](https://community.traefik.io/u/flweber)\
**Post date:** [July 27, 2021, 7:12am UTC](https://community.traefik.io/t/traefik2-4-uses-a-non-existent-resolver-inwx/11283/3 "2021-07-27T07:12:15Z")

</div>

Hello @daniel.tomcej ,  
sorry for my late reply.  
I have found the following output in my logs:

```auto
time="2021-07-26T09:56:43Z" level=error msg="The ACME resolver \"inwx\" is skipped from the resolvers list because: unable to get ACME account: permissions 660 for /data/acme.json are too open, please use 600"

```

I fixed it with an init container which changes the permission before traefik starts:

```auto
deployment:
  initContainers:
    - name: volume-permissions
      image: busybox:1.31.1
      command: ["sh", "-c", "chmod -Rv 600 /data/*"]
      volumeMounts:
        - name: data
          mountPath: /data

```

The first startup of traefik works fine but a `helm upgrade` broke it. With the init container all is working fine but is there a better way to fix this issue?

---

_[View the full topic](https://community.traefik.io/t/traefik2-4-uses-a-non-existent-resolver-inwx/11283)._
