# Traefik Kubernetes UDP

**URL:** <https://community.traefik.io/t/traefik-kubernetes-udp/14460>\
**Category:** Traefik v2\
**Tags:** kubernetes-crd\
**Created:** [May 13, 2022, 11:11am UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460 "2022-05-13T11:11:38Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tothalex](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/tothalex/32/5332_2.png) [@tothalex](https://community.traefik.io/u/tothalex)\
**Post date:** [May 13, 2022, 11:11am UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/1 "2022-05-13T11:11:38Z")

</div>

Hey!

I'm trying to use the traefik as UDP Load Balancer, I created the deployment, service, udp ingress route also created a UDP entry point but I keep receiving this error `Error syncing load balancer: failed to ensure load balancer: failed to build load-balancer request: no health check port of protocol TCP found`, and I don't know how should I fix this.

---

<div class="post-metadata">

**Author:** ![moutoum](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/moutoum/32/5325_2.png) [@moutoum](https://community.traefik.io/u/moutoum)\
**Post date:** [May 19, 2022, 7:48am UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/2 "2022-05-19T07:48:18Z")

</div>

Hi @tothalex,  
Thanks for your interest in Traefik.

It is actually hard to try to reproduce the issue. Could you provide us your configurations?

---

<div class="post-metadata">

**Author:** ![tothalex](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/tothalex/32/5332_2.png) [@tothalex](https://community.traefik.io/u/tothalex)\
**Post date:** [May 19, 2022, 1:34pm UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/3 "2022-05-19T13:34:35Z")

</div>

Hey @moutoum the issue was because of the platform, I used DigitalOcean. I moved on with AWS so what I did is that I deployed a kubernetes cluster to a EC2 instance with kops, but now I have a different issue `Protocol UDP is not supported by LoadBalancer`. This error is inside of the `service/traefik-udp` events. So my question is how can I fix this? Am I need to use nlb with traefik in order to get this done or how? Where can I even use the traefik-udp service if neither DigitalOcean nor AWS EC2 can't launch the `service/traefik-udp`.

---

<div class="post-metadata">

**Author:** ![tothalex](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/tothalex/32/5332_2.png) [@tothalex](https://community.traefik.io/u/tothalex)\
**Post date:** [May 19, 2022, 1:37pm UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/4 "2022-05-19T13:37:33Z")

</div>

I just simply installed the traefik with helm by enabling the udp within the values

```auto
traefik:
  ports:
    udp:
      port: 3000
      expose: true
      exposedPort: 3000
      protocol: UDP

```

---

<div class="post-metadata">

**Author:** ![moutoum](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/moutoum/32/5325_2.png) [@moutoum](https://community.traefik.io/u/moutoum)\
**Post date:** [May 20, 2022, 7:21am UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/5 "2022-05-20T07:21:05Z")

</div>

Hi @tothalex,

This error message comes from your kubernetes cloud provider.  
It means that AWS doesn't support your [LoadBalancer](https://docs.aws.amazon.com/eks/latest/userguide/alb-ingress.html) definition as I think you are using an [ApplicationLoadBalancer](https://docs.aws.amazon.com/eks/latest/userguide/alb-ingress.html) which is L7. I think you are right by saying that you have to use a [NetworkLoadBalancer](https://docs.aws.amazon.com/eks/latest/userguide/network-load-balancing.html). Luckily, kops supports this `LoadBalancer` mode since 1.19.  
Could you please have a look at [this](https://github.com/kubernetes/kops/issues/5762#issuecomment-740687749)?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/containo/original/2X/b/bd81ebdb578656e76e56ff3cc3eed021d3ba132d.png) [@system](https://community.traefik.io/u/system)\
**Post date:** [May 23, 2022, 7:21am UTC](https://community.traefik.io/t/traefik-kubernetes-udp/14460/6 "2022-05-23T07:21:20Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
