Problem renewing the cert with DNS-01 challenge

Hello everyone!

I've been using Docker + Traefik + LetsEncrypt for months, but now the certs expired a few days ago. Not sure why but it did not renew automatically. I tried to renew the cert with no success!. My method is the DNS-01 challenge. I tried with DuckDNS and with Dynu, but I always get this error:

{"level":"error","msg":"Unable to obtain ACME certificate for domains \",*\" : unable to generate a certificate for the domains [ *]: error: one or more domains had a problem:\n[*] time limit exceeded: last error: NS returned REFUSED for\n[] time limit exceeded: last error: NS returned REFUSED for\n","providerName":"letsencrypt.acme","time":"2020-10-23T21:04:11-03:00"}

I was checking many pages, but I did not found any clue about my problem. I truly believe it is a simple problem, but I am just not seeing it.

My static configuration is as follow:

certResolver = "letsencrypt"
main = ""
sans = ["*"]

email = ""
storage = "acme.json"
caServer = ""

provider = "dynu"
delayBeforeCheck = 30
resolvers = ["", ""]

and the dynamic one is:

   - traefik.enable=true

Any advice?


This text will be hidden

Hey, I found a way to resolve this issue. There is a global option in the Lego documentations that works for my:

   --dns.disable-cp             By setting this flag to true disables the need to wait for the propagation of the TXT record to all authoritative name servers.

So I modified my static configuration by adding this line:

disablePropagationCheck = true

New the cert is there and working

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.