# Non blocking errors in traefik with cert-manager

**URL:** https://community.traefik.io/t/non-blocking-errors-in-traefik-with-cert-manager/23703
**Category:** Traefik v3 (latest)
**Tags:** kubernetes-crd, kubernetes-ingress
**Created:** [July 24, 2024, 5:48pm UTC](https://community.traefik.io/t/non-blocking-errors-in-traefik-with-cert-manager/23703 "2024-07-24T17:48:10Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Lorenzo](https://avatars.discourse-cdn.com/v4/letter/l/4da419/32.png) [@Lorenzo](https://community.traefik.io/u/Lorenzo)
#### Post date: [July 24, 2024, 5:48pm UTC](https://community.traefik.io/t/non-blocking-errors-in-traefik-with-cert-manager/23703/1 "2024-07-24T17:48:10Z")

</div>

Hi,  
I'm getting errors in the traefik's logs

```auto
2024-07-24T17:27:53Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=argo-server-ingressroute namespace=cert-manager providerName=kubernetescrd
2024-07-24T17:27:53Z ERR Cannot create service error="endpoints not found" ingress=cm-acme-http-solver-gxtfs namespace=cert-manager providerName=kubernetes serviceName=cm-acme-http-solver-6lmtx servicePort=&ServiceBackendPort{Name:,Number:8089,}
2024-07-24T17:27:53Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=grafana-ingressroute namespace=cert-manager providerName=kubernetescrd
2024-07-24T17:27:53Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=argo-server-ingressroute namespace=cert-manager providerName=kubernetescrd
2024-07-24T17:27:53Z ERR Skipping service: no endpoints found ingress=cm-acme-http-solver-gxtfs namespace=cert-manager providerName=kubernetes serviceName=cm-acme-http-solver-6lmtx servicePort=&ServiceBackendPort{Name:,Number:8089,}
2024-07-24T17:27:56Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=argo-server-ingressroute namespace=cert-manager providerName=kubernetescrd
2024-07-24T17:27:56Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=grafana-ingressroute namespace=cert-manager providerName=kubernetescrd
2024-07-24T17:28:33Z ERR Cannot create service error="service not found" ingress=cm-acme-http-solver-gxtfs namespace=cert-manager providerName=kubernetes serviceName=cm-acme-http-solver-6lmtx servicePort=&ServiceBackendPort{Name:,Number:8089,}
2024-07-24T17:28:33Z ERR Error configuring TLS error="secret cert-manager/cert does not exist" ingress=argo-server-ingressroute namespace=cert-manager providerName=kubernetescrd

```

but after some times everything gets fine (path and certificate)

one of my ingress look like

```auto
apiVersion: traefik.io/v1alpha1
kind: IngressRoute
metadata:
  name: argo-server-ingressroute
  namespace: cert-manager
spec:
  entryPoints:
    - websecure
  tls:
    secretName: cert
  routes:
    - kind: Rule
      services:
        - name: argo-server
          port: 2746
          namespace: argo
      match: Host(`xxx.com`) && PathPrefix(`/`)
---
apiVersion: traefik.io/v1alpha1
kind: IngressRoute
metadata:
  name: argo-server-ingressroute-http
  namespace: cert-manager
spec:
  entryPoints:
    - web
  routes:
    - kind: Rule
      services:
        - name: argo-server
          port: 2746
          namespace: argo
          match: Host(`xxx.com`) && PathPrefix(`/`)
      middlewares:
        - name: http-redirect
          namespace: traefik

```

and my value file

```auto
image:
  tag: v3.0.4

ingressRoute:
  dashboard:
    enabled: false

ingressClass:
  enabled: true
  isDefaultClass: true

providers:
  kubernetesCRD:
    enabled: true

service:
  enabled: true
  type: LoadBalancer

additionalArguments:
  - --providers.kubernetescrd.allowCrossNamespace=true

```

My guess is that the traefik pods are faster than the cert-manager pods  
any idea to avoid getting theses errors ?

---

<div class="post-metadata">

### Author: ![LearningNetrunner](https://avatars.discourse-cdn.com/v4/letter/l/eada6e/32.png) [@LearningNetrunner](https://community.traefik.io/u/LearningNetrunner)
#### Post date: [December 12, 2024, 9:11am UTC](https://community.traefik.io/t/non-blocking-errors-in-traefik-with-cert-manager/23703/2 "2024-12-12T09:11:54Z")

</div>

hello have you solved it?  
I have a similar error with traefik 3.2.1.

```auto
ERR Skipping service: no endpoints found ingress=app-ingress namespace=default providerName=kubernetes serviceName=app-frontend servicePort=&ServiceBackendPort{Name:app-frontend,Number:0,}
ERR Skipping service: no endpoints found ingress=app-ssl-ingress namespace=default providerName=kubernetes serviceName=app-frontend servicePort=&ServiceBackendPort{Name:app-frontend,Number:0,}

```
