# msg="Could not retrieve CanonizedHost, rejecting "

**URL:** https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651
**Category:** Traefik v2
**Tags:** file
**Created:** [April 22, 2020, 8:10pm UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651 "2020-04-22T20:10:42Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Daxcor](https://avatars.discourse-cdn.com/v4/letter/d/848f3c/32.png) [@Daxcor](https://community.traefik.io/u/Daxcor)
#### Post date: [April 22, 2020, 8:10pm UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651/1 "2020-04-22T20:10:42Z")

</div>

time="2020-04-22T12:59:29-07:00" level=warning msg="Could not retrieve CanonizedHost, rejecting ".

What does this message mean, should I be concerned?

thanks  
Brad

---

<div class="post-metadata">

### Author: ![mekstrem](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/mekstrem/32/1998_2.png) [@mekstrem](https://community.traefik.io/u/mekstrem)
#### Post date: [April 29, 2020, 8:46am UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651/2 "2020-04-29T08:46:57Z")

</div>

Hi Daxcor,

Are you using a LB with health checks by any chance? I've encountered this with F5 Health Monitor that sends HTTP/1.0 requests without a host header. The accompanied URL to that message should say if the request was done with HTTP/1.0 or not. To resolve this can you either add a host header to the HTTP/1.0 request or upgrade to HTTP/1.1. This is how I've solved this.

---

<div class="post-metadata">

### Author: ![sandroden](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/sandroden/32/1571_2.png) [@sandroden](https://community.traefik.io/u/sandroden)
#### Post date: [July 5, 2021, 9:44pm UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651/3 "2021-07-05T21:44:23Z")

</div>

I have the same problem, the LoadBalancer I'm using is from Scaleway and they don't allow me to add headers. Any hint on a different LoadBalancer that can be used to grant ha to our kubernetes cluster on prem?

---

<div class="post-metadata">

### Author: ![daniel.tomcej](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/daniel.tomcej/32/262_2.png) [@daniel.tomcej](https://community.traefik.io/u/daniel.tomcej)
#### Post date: [July 6, 2021, 10:24pm UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651/4 "2021-07-06T22:24:36Z")

</div>

Hello all, the message received is due to an incoming request not containing a Host header, undoubtedly due to being HTTP/1.0.

This is not a concern, and can be ignored safely. There is a PR to remove this warning for HTTP/1.9 connections:[Ignore http 1.0 request host missing errors by dtomcej · Pull Request #8252 · traefik/traefik · GitHub](https://github.com/traefik/traefik/pull/8252)

Hello @sandroden, if you are looking for on-prem LBs, you should look at MetalLB: [https://metallb.universe.tf/](https://metallb.universe.tf/)

---

<div class="post-metadata">

### Author: ![sandroden](https://sea2.discourse-cdn.com/flex020/user_avatar/community.traefik.io/sandroden/32/1571_2.png) [@sandroden](https://community.traefik.io/u/sandroden)
#### Post date: [July 6, 2021, 10:49pm UTC](https://community.traefik.io/t/msg-could-not-retrieve-canonizedhost-rejecting/5651/5 "2021-07-06T22:49:48Z")

</div>

Hi @daniel.tomcej

> [@daniel.tomcej](#):
>
> This is not a concern, and can be ignored safely.

this is reported by someone, my experience is different [as reported here](https://github.com/traefik/traefik/issues/5501#issuecomment-874267329)

> [@daniel.tomcej](#):
>
> if you are looking for on-prem LBs, you should look at MetalLB: [https://metallb.universe.tf/](https://metallb.universe.tf/)

If I'm correct that would not help in implementing High Availability. I think an external LaodBalancer that checks which nodes are reachable can give me more resilience. I have nodes in 2 different datacenters, on the contrary the entry point would not be under HA with metallb.
