Invalid token when installing Traefik Pilot plugins

Hello guys!

I get a following error when I try installing a plugin from yaml file.
I install the plugin with 'additionalArguments' block like so:

additionalArguments:
  - "--entrypoints.web.address=:8000"
  - "--entrypoints.websecure.address=:8443"
  - "--experimental.pilot.token=<MY_TOKEN>"
  - "--experimental.plugins.plugin-blockpath.modulename=github.com/containous/plugin-blockpath"
  - "--experimental.plugins.plugin-blockpath.version=v0.1.2"

And I made changes in the 'securityContext' like so, because the plugin couldn't use the disk:

securityContext:
  readOnlyRootFilesystem: false
  runAsGroup: 0
  runAsUser: 0
  runAsNonRoot: false
#  readOnlyRootFilesystem: true
#  runAsGroup: 65532
#  runAsNonRoot: true
#  runAsUser: 65532

The error log:

traefik.go:76: command traefik error: failed to download plugin github.com/containous/plugin-blockpath: error: 400: {"error":"invalid token"}

Could I request some help with this please? Thank you in advance!

Hello,

We have found and fixed the problem: yesterday one of our internal tokens expired, which produced an error while downloading the plugins. The problem is now fixed.

Thank you.

1 Like