# Connection refused when accessing container using curl

**URL:** <https://community.traefik.io/t/connection-refused-when-accessing-container-using-curl/10896>\
**Category:** Traefik v2\
**Tags:** docker\
**Created:** [June 11, 2021, 1:29am UTC](https://community.traefik.io/t/connection-refused-when-accessing-container-using-curl/10896 "2021-06-11T01:29:30Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![milwell](https://avatars.discourse-cdn.com/v4/letter/m/898d66/32.png) [@milwell](https://community.traefik.io/u/milwell)\
**Post date:** [June 11, 2021, 1:29am UTC](https://community.traefik.io/t/connection-refused-when-accessing-container-using-curl/10896/1 "2021-06-11T01:29:30Z")

</div>

When I use curl -v [http://host1](http://host1) from my traefik container it says connection refused.  
Happens when I stop start machine. After a while it's ok.  
Below is some of my docker-compose code:

services:  
traefik:  
image: traefik:2.4  
container\_name: traefik  
command:  
- --providers.docker  
- --entrypoints.web.address=:80  
- --entrypoints.websecure.address=:443  
- --entrypoints.web.http.redirections.entryPoint.to=websecure  
- --entrypoints.web.http.redirections.entryPoint.scheme=https  
- --entrypoints.web.http.redirections.entrypoint.permanent=true  
- [--certificatesResolvers.le.acme.email=myemail@gmail.com](mailto:--certificatesResolvers.le.acme.email=myemail@gmail.com)  
- --certificatesResolvers.le.acme.storage=/acme.json  
- --certificatesResolvers.le.acme.tlschallenge=true  
# - --log.level=debug  
host1:  
......  
labels:  
- "traefik.http.routers.host1.rule=Host(`mydomain.com`)"  
- "traefik.http.routers.host1.tls=true"  
- "traefik.http.routers.host1.tls.certresolver=le"  
- "traefik.port=80"  
- "traefik.enable=true"
