# Latest

**URL:** https://community.traefik.io/latest.md

[Latest](https://community.traefik.io/latest.md) · [Categories](https://community.traefik.io/categories.md) · [Tags](https://community.traefik.io/tags.md)

---

## [Responder - a new static response plugin](https://community.traefik.io/t/responder-a-new-static-response-plugin/30243)

<div class="topic-metadata">

**Author:** [@gabay](https://community.traefik.io/u/gabay)\
**Replies:** 0\
**Last updated:** [September 19, 2026, 3:19pm UTC](https://community.traefik.io/t/responder-a-new-static-response-plugin/30243 "2026-09-19T15:19:34Z")

</div>

Hey everyone. I recently migrated from SWAG to Traefik and found it very easy and intuitive However - Traefik does not support static responses at all, and the plugins I found were quite cumbersome, as every static res…

---

## [better graceful restart with Kubernetes](https://community.traefik.io/t/better-graceful-restart-with-kubernetes/29979)

<div class="topic-metadata">

**Author:** [@adk-swisstopo](https://community.traefik.io/u/adk-swisstopo)\
**Replies:** 4\
**Last updated:** [September 15, 2026, 8:09am UTC](https://community.traefik.io/t/better-graceful-restart-with-kubernetes/29979 "2026-09-15T08:09:51Z")

</div>

The current recommendation to gracefully handle Kubernetes-initiated restarts is to add a preSleep hook. This generally works but is subject to race conditions and delays the restart for longer than strictly necessary (s…

---

## [Traefik 3.7.13 Health Check](https://community.traefik.io/t/traefik-3-7-13-health-check/30241)

<div class="topic-metadata">

**Author:** [@blackneil](https://community.traefik.io/u/blackneil)\
**Replies:** 1\
**Last updated:** [September 14, 2026, 7:39pm UTC](https://community.traefik.io/t/traefik-3-7-13-health-check/30241 "2026-09-14T19:39:18Z")

</div>

Hello, for some test yesterday, I have added two dead services in a route with a health check, like this into the dynamic config. healthCheck: interval: 10s timeout: 3s I can quickly see the both are de…

---

## [Kubernetes Gateway provider: BackendTLSPolicy Ancestors limit exceeded](https://community.traefik.io/t/kubernetes-gateway-provider-backendtlspolicy-ancestors-limit-exceeded/29961)

<div class="topic-metadata">

**Author:** [@dklenke](https://community.traefik.io/u/dklenke)\
**Replies:** 1\
**Last updated:** [September 14, 2026, 7:40am UTC](https://community.traefik.io/t/kubernetes-gateway-provider-backendtlspolicy-ancestors-limit-exceeded/29961 "2026-09-14T07:40:35Z")

</div>

Hi, I am running traefik v3.7.5 deployed with the official helm chart 41.0.0 in Kubernetes v1.35.5. I have the Kubernetes Gateway API CRDs installed in version v1.5.1. My issue is that the Gateway API limits the List o…

---

## [Traefik not creating routers from docker labels](https://community.traefik.io/t/traefik-not-creating-routers-from-docker-labels/30235)

<div class="topic-metadata">

**Author:** [@RedToxyl](https://community.traefik.io/u/RedToxyl)\
**Replies:** 2\
**Last updated:** [September 13, 2026, 10:36am UTC](https://community.traefik.io/t/traefik-not-creating-routers-from-docker-labels/30235 "2026-09-13T10:36:16Z")

</div>

Hi there I am trying to move from a .yaml to docker labels based system. However, Traefik sometimes doesn't create routers from given docker labels. Sometimes it does, and I cannot for the life of me figure out why. Th…

---

## [Unable to follow "Getting Started" guide, cannot install Traefik on Kubernetes via Helm](https://community.traefik.io/t/unable-to-follow-getting-started-guide-cannot-install-traefik-on-kubernetes-via-helm/29881)

<div class="topic-metadata">

**Author:** [@julianwong](https://community.traefik.io/u/julianwong)\
**Replies:** 1\
**Last updated:** [September 10, 2026, 11:15am UTC](https://community.traefik.io/t/unable-to-follow-getting-started-guide-cannot-install-traefik-on-kubernetes-via-helm/29881 "2026-09-10T11:15:24Z")

</div>

Hello, I'm trying to follow the Kubernetes setup for Traefik here: However, I am unable to successfully complete the step "Install the Traefik Using the Helm Values." After installing PS\> helm install traefik traefik…

---

## [Creating landing page from http endpoints](https://community.traefik.io/t/creating-landing-page-from-http-endpoints/28834)

<div class="topic-metadata">

**Author:** [@klobass-skoda](https://community.traefik.io/u/klobass-skoda)\
**Replies:** 2\
**Last updated:** [September 8, 2026, 4:07pm UTC](https://community.traefik.io/t/creating-landing-page-from-http-endpoints/28834 "2026-09-08T16:07:00Z")

</div>

Hi everyone, I've been searching for a while now for a simple way to create a basic landing page directly from an HTTP endpoints using Traefik. My goal is to have a specific path return a simple, static HTML page or ev…

---

## [ACME Cloudflare not working after 3.7.6+](https://community.traefik.io/t/acme-cloudflare-not-working-after-3-7-6/29983)

<div class="topic-metadata">

**Author:** [@dhjensen](https://community.traefik.io/u/dhjensen)\
**Replies:** 22\
**Last updated:** [September 8, 2026, 2:48pm UTC](https://community.traefik.io/t/acme-cloudflare-not-working-after-3-7-6/29983 "2026-09-08T14:48:23Z")

</div>

Hi guys, After I upgraded to version 3.7.6+ (Noticed this the first time in 3.7.8) I see the behavior in the log below. The behavior seen in the log goes away if I revert to version 3.7.5. If you need more info let me …

---

## [New security update for Traefik 2.11 (2.11.57) and 3.7 (3.7.13)](https://community.traefik.io/t/new-security-update-for-traefik-2-11-2-11-57-and-3-7-3-7-13/30229)

<div class="topic-metadata">

**Author:** [@nicomengin](https://community.traefik.io/u/nicomengin)\
**Replies:** 0\
**Last updated:** [September 7, 2026, 12:26pm UTC](https://community.traefik.io/t/new-security-update-for-traefik-2-11-2-11-57-and-3-7-3-7-13/30229 "2026-09-07T12:26:21Z")

</div>

Hi everyone, We have released new security updates for Traefik Proxy: 2.11.57 and 3.7.13. These releases fix the following security advisories: \[Critical\] GHSA-qqjf-53cj-pwvv: HTTP/3 backend NTLM/Negotiate connection…

---

## [Traefik Middleware Plugin Download Fails Sites Dependent on It](https://community.traefik.io/t/traefik-middleware-plugin-download-fails-sites-dependent-on-it/29760)

<div class="topic-metadata">

**Author:** [@j0nny55555](https://community.traefik.io/u/j0nny55555)\
**Replies:** 1\
**Last updated:** [September 6, 2026, 6:08am UTC](https://community.traefik.io/t/traefik-middleware-plugin-download-fails-sites-dependent-on-it/29760 "2026-09-06T06:08:48Z")

</div>

Really quick, the subject describes it - and I found the solution and was curious if there was any intent to make this more standardized, at least in documentation? The Traefik instances will come up, but the sites that…

---

## [Traefik 3.7.12 Gateway API Setup on Kubernetes 1.36](https://community.traefik.io/t/traefik-3-7-12-gateway-api-setup-on-kubernetes-1-36/30227)

<div class="topic-metadata">

**Author:** [@kntambwe](https://community.traefik.io/u/kntambwe)\
**Replies:** 1\
**Last updated:** [September 5, 2026, 6:26pm UTC](https://community.traefik.io/t/traefik-3-7-12-gateway-api-setup-on-kubernetes-1-36/30227 "2026-09-05T18:26:34Z")

</div>

Hello Community, I am trying to setup Gateway API with traefik 3.7.12 on kubernetes 1.36. Whenever I run my yaml code to create GatewayClass, status is unknown $ kubectl get gatewayclass NAME CONTROLLER …

---

## [Error renewing ACME certificate: could not determine authoritative nameservers](https://community.traefik.io/t/error-renewing-acme-certificate-could-not-determine-authoritative-nameservers/30218)

<div class="topic-metadata">

**Author:** [@plating510](https://community.traefik.io/u/plating510)\
**Replies:** 3\
**Last updated:** [September 3, 2026, 10:52am UTC](https://community.traefik.io/t/error-renewing-acme-certificate-could-not-determine-authoritative-nameservers/30218 "2026-09-03T10:52:42Z")

</div>

I'm having trouble renewing my wildcard certificates via the DNS-01 challenge: I can see the TXT record being created at mijn.host, and then being deleted after a minute. traefik logs: traefik: ERR Error renewing ACME…

---

## [Traefik web UI admin panel](https://community.traefik.io/t/traefik-web-ui-admin-panel/28794)

<div class="topic-metadata">

**Author:** [@Janhouse](https://community.traefik.io/u/Janhouse)\
**Replies:** 4\
**Last updated:** [September 3, 2026, 6:38am UTC](https://community.traefik.io/t/traefik-web-ui-admin-panel/28794 "2026-09-03T06:38:32Z")

</div>

Inspired by Nginx Proxy Manager, Pangolin and Tailscale Funnel, I am playing around the idea of web based admin panel for managing Traefik dynamic configuration. This is mainly for the homelab community. :slight\_smile: …

---

## [Forwarding traffic to a game server running on Pterodactyl](https://community.traefik.io/t/forwarding-traffic-to-a-game-server-running-on-pterodactyl/23657)

<div class="topic-metadata">

**Author:** [@molemanx](https://community.traefik.io/u/molemanx)\
**Replies:** 7\
**Last updated:** [August 30, 2026, 5:53am UTC](https://community.traefik.io/t/forwarding-traffic-to-a-game-server-running-on-pterodactyl/23657 "2026-08-30T05:53:13Z")

</div>

Unsure if this is the correct place for issues like this, however I’ve been trying to set up a game server running on pterodactyl over the last week and I’m on the very last hurdle. I’ve successfully set up a game serve…

---

## [Plugin integrity check fails for github.com/fosrl/badger (Pangolin's plugin) v1.6.0 and v1.6.1](https://community.traefik.io/t/plugin-integrity-check-fails-for-github-com-fosrl-badger-pangolins-plugin-v1-6-0-and-v1-6-1/30199)

<div class="topic-metadata">

**Author:** [@miloschwartz](https://community.traefik.io/u/miloschwartz)\
**Replies:** 5\
**Last updated:** [August 27, 2026, 3:43pm UTC](https://community.traefik.io/t/plugin-integrity-check-fails-for-github-com-fosrl-badger-pangolins-plugin-v1-6-0-and-v1-6-1/30199 "2026-08-27T15:43:27Z")

</div>

Hi, I'm the maintainer of the Pangolin Badger plugin (GitHub - fosrl/badger: Traefik middleware authentication bouncer for Pangolin · GitHub). We're seeing Traefik fail to install v1.6.0 and v1.6.1 with a plugin integri…

---

## [New Security Update for Traefik 2.11 (2.11.52) and 3.7 (3.7.12)](https://community.traefik.io/t/new-security-update-for-traefik-2-11-2-11-52-and-3-7-3-7-12/30211)

<div class="topic-metadata">

**Author:** [@nicomengin](https://community.traefik.io/u/nicomengin)\
**Replies:** 0\
**Last updated:** [August 27, 2026, 8:31am UTC](https://community.traefik.io/t/new-security-update-for-traefik-2-11-2-11-52-and-3-7-3-7-12/30211 "2026-08-27T08:31:05Z")

</div>

On August 26, 2026, we patched the following vulnerabilities in Traefik Proxy 2.11.56 and 3.7.12: Advisory GHSA-cjr6-pf59-jq29 (CVE pending) — fixed in 3.7.12 Advisory GHSA-7ghq-v6jf-g56c (CVE pending) — fixed in 2.11.…

---

## [Headscale node access issues](https://community.traefik.io/t/headscale-node-access-issues/30207)

<div class="topic-metadata">

**Author:** [@boardlord1](https://community.traefik.io/u/boardlord1)\
**Replies:** 2\
**Last updated:** [August 26, 2026, 6:53am UTC](https://community.traefik.io/t/headscale-node-access-issues/30207 "2026-08-26T06:53:00Z")

</div>

I've run Headscale behind Nginx Proxy Manager without problems for a long time, but I've decided to migrate my whole reverse proxy setup to Traefik. Overall everything went fine, but I'm having problems with Headscale. T…

---

## [HTTP/1.0 Protocol Downgrade (PCI DSS) - Is it possible to reject HTTP/1.0 requests in Traefik?](https://community.traefik.io/t/http-1-0-protocol-downgrade-pci-dss-is-it-possible-to-reject-http-1-0-requests-in-traefik/29981)

<div class="topic-metadata">

**Author:** [@westsidetechsolution](https://community.traefik.io/u/westsidetechsolution)\
**Replies:** 2\
**Last updated:** [August 25, 2026, 7:48am UTC](https://community.traefik.io/t/http-1-0-protocol-downgrade-pci-dss-is-it-possible-to-reject-http-1-0-requests-in-traefik/29981 "2026-08-25T07:48:03Z")

</div>

I'm trying to satisfy a PCI DSS ASV scan that fails with the following finding: HTTP/1.0 Protocol Downgrade Detected The recommendation from the PCI vendor is that the server should reject HTTP/1.0 requests and only …

---

## [Helm chart repo down?](https://community.traefik.io/t/helm-chart-repo-down/30141)

<div class="topic-metadata">

**Author:** [@rensBL](https://community.traefik.io/u/rensBL)\
**Replies:** 3\
**Last updated:** [August 19, 2026, 7:33am UTC](https://community.traefik.io/t/helm-chart-repo-down/30141 "2026-08-19T07:33:16Z")

</div>

Is there a known issue with the Helm chart server? I'm getting the following when trying to browse the repo: Unable to locate chart traefik: looks like "https://helm.traefik.io/traefik" is not a valid chart repository…

---

## [In k3s how to whitelist specific namespaces to work with traefik?](https://community.traefik.io/t/in-k3s-how-to-whitelist-specific-namespaces-to-work-with-traefik/29962)

<div class="topic-metadata">

**Author:** [@SpiderUnderUrBed](https://community.traefik.io/u/SpiderUnderUrBed)\
**Replies:** 1\
**Last updated:** [August 17, 2026, 7:30pm UTC](https://community.traefik.io/t/in-k3s-how-to-whitelist-specific-namespaces-to-work-with-traefik/29962 "2026-08-17T19:30:00Z")

</div>

In k3s how to whitelist specific namespaces to work with traefik? There is an allowCrossNamespace option for traefik, somewhere, helm or just in its plain setup, and I had to have enabled it because there was the UI for …

---

## [New version information on the dashboard?](https://community.traefik.io/t/new-version-information-on-the-dashboard/29999)

<div class="topic-metadata">

**Author:** [@mbender](https://community.traefik.io/u/mbender)\
**Replies:** 1\
**Last updated:** [August 17, 2026, 2:35pm UTC](https://community.traefik.io/t/new-version-information-on-the-dashboard/29999 "2026-08-17T14:35:31Z")

</div>

Is it me, or is there no notification about a new version for Traefik visible on the dashboard? Which is a bit strange because that information IS available in, say, Traefik's docker logs. Would it be possible to have t…

---

## [Per-port mTLS on the same SNI hostname — supported, or does it require distinct hostnames? (v3.7.4, Kubernetes CRD)](https://community.traefik.io/t/per-port-mtls-on-the-same-sni-hostname-supported-or-does-it-require-distinct-hostnames-v3-7-4-kubernetes-crd/29969)

<div class="topic-metadata">

**Author:** [@thelever](https://community.traefik.io/u/thelever)\
**Replies:** 1\
**Last updated:** [August 15, 2026, 12:13pm UTC](https://community.traefik.io/t/per-port-mtls-on-the-same-sni-hostname-supported-or-does-it-require-distinct-hostnames-v3-7-4-kubernetes-crd/29969 "2026-08-15T12:13:20Z")

</div>

I'm trying to serve one hostname (app.example.com) with different client-cert requirements per port: cert-free on :443 (websecure) for the browser/login routes, and RequireAndVerifyClientCert on a second entrypoint :8443…

---

## [TLS certificates shared by all routes?](https://community.traefik.io/t/tls-certificates-shared-by-all-routes/30115)

<div class="topic-metadata">

**Author:** [@razr](https://community.traefik.io/u/razr)\
**Replies:** 1\
**Last updated:** [August 14, 2026, 11:28am UTC](https://community.traefik.io/t/tls-certificates-shared-by-all-routes/30115 "2026-08-14T11:28:57Z")

</div>

I noticed something when I tested copying an Ingress resource: When I have two ingress resources with the same hosts, but only one references a TLS secret, both routers in Traefik have TLS. I noticed this when I copied …

---

## [crowdsec-bouncer-traefik-plugin: error: 500](https://community.traefik.io/t/crowdsec-bouncer-traefik-plugin-error-500/30142)

<div class="topic-metadata">

**Author:** [@boomshiva](https://community.traefik.io/u/boomshiva)\
**Replies:** 1\
**Last updated:** [August 13, 2026, 6:39pm UTC](https://community.traefik.io/t/crowdsec-bouncer-traefik-plugin-error-500/30142 "2026-08-13T18:39:57Z")

</div>

i am not able to download the plugin. getting error 500. i haven't changed anything, using the same config from ages. {"level":"error","plugins":\["crowdsec-bouncer"\],"error":"unable to set up plugins environment: unable…

---

## [Using the error middleware always trigger an error: "the service "@provider" does not exist"](https://community.traefik.io/t/using-the-error-middleware-always-trigger-an-error-the-service-provider-does-not-exist/29946)

<div class="topic-metadata">

**Author:** [@NotaInutilis](https://community.traefik.io/u/NotaInutilis)\
**Replies:** 5\
**Last updated:** [August 10, 2026, 1:26pm UTC](https://community.traefik.io/t/using-the-error-middleware-always-trigger-an-error-the-service-provider-does-not-exist/29946 "2026-08-10T13:26:38Z")

</div>

Hi, I'd like to ask for some help with using the error middleware with Traefik 3.7.5 on Docker. I'm getting an error which looks unrelated and I'm not sure if it's a configuration issue or a bug. I'm trying to create an…

---

## [Upgrading the chart 40.x (from 39.0.9) will block any ingress traefik](https://community.traefik.io/t/upgrading-the-chart-40-x-from-39-0-9-will-block-any-ingress-traefik/30118)

<div class="topic-metadata">

**Author:** [@EugenMayer](https://community.traefik.io/u/EugenMayer)\
**Replies:** 1\
**Last updated:** [August 8, 2026, 8:37am UTC](https://community.traefik.io/t/upgrading-the-chart-40-x-from-39-0-9-will-block-any-ingress-traefik/30118 "2026-08-08T08:37:31Z")

</div>

Env: rke2 v1.36.3+rke2r1 with 4 nodes (1 plane, 3 workers) i'am not using rke2 traefik integration/chart. I exclude ingress and deploy the traefik chart myself all nodes are barebones Kernel: 7.0.0 Ubuntu 24.04 C…

---

## [Resilient routing on invalid middlewares](https://community.traefik.io/t/resilient-routing-on-invalid-middlewares/29776)

<div class="topic-metadata">

**Author:** [@pacoguzman](https://community.traefik.io/u/pacoguzman)\
**Replies:** 3\
**Last updated:** [August 5, 2026, 8:31am UTC](https://community.traefik.io/t/resilient-routing-on-invalid-middlewares/29776 "2026-08-05T08:31:50Z")

</div>

We faced a problem when an existing router defined through an Ingress kubernetes resource is modified to add a routing middleware, if the reference to the middleware does not exist the routing will be marked as disabled …

---

## [Why are 3.6 releases still being made when no support is indicated?](https://community.traefik.io/t/why-are-3-6-releases-still-being-made-when-no-support-is-indicated/29967)

<div class="topic-metadata">

**Author:** [@glenb](https://community.traefik.io/u/glenb)\
**Replies:** 2\
**Last updated:** [August 3, 2026, 12:01pm UTC](https://community.traefik.io/t/why-are-3-6-releases-still-being-made-when-no-support-is-indicated/29967 "2026-08-03T12:01:43Z")

</div>

On the Releases deprecation notice page, it's clearly stated that Traefik version 3.6 has ended all support as of May 5. However, substantial releases are still being made on the GitHub repository as lately as yesterday.…

---

## [Explain this to me like I'm 5 - Internal Cert being ignored - unable to setup](https://community.traefik.io/t/explain-this-to-me-like-im-5-internal-cert-being-ignored-unable-to-setup/30052)

<div class="topic-metadata">

**Author:** [@sham](https://community.traefik.io/u/sham)\
**Replies:** 3\
**Last updated:** [August 1, 2026, 6:51am UTC](https://community.traefik.io/t/explain-this-to-me-like-im-5-internal-cert-being-ignored-unable-to-setup/30052 "2026-08-01T06:51:06Z")

</div>

I'm not using docker, and have no idea how to figure that out, so I'm running an LXC in ProxMox. My domain is wildcard flushed through a cloudflared tunnel, all using this scripting setup: I am attempting to run nexc…

---

## [SSL certificate not working for a service using Traefik in Docker Swarm](https://community.traefik.io/t/ssl-certificate-not-working-for-a-service-using-traefik-in-docker-swarm/26187)

<div class="topic-metadata">

**Author:** [@JoaoPasserini](https://community.traefik.io/u/JoaoPasserini)\
**Replies:** 6\
**Last updated:** [July 26, 2026, 12:10pm UTC](https://community.traefik.io/t/ssl-certificate-not-working-for-a-service-using-traefik-in-docker-swarm/26187 "2026-07-26T12:10:14Z")

</div>

Hello, I'm experiencing an issue where my Traefik setup is not generating a Let's Encrypt SSL certificate for one of my services. Instead, it uses the default "Traefik Default Cert". My setup includes: VPS: Hetzner Se…

[Next page](https://community.traefik.io/latest.md?page=1)
