# Traefik v3 (latest)

**URL:** https://community.traefik.io/c/traefik/traefik-v3/21.md

[Latest](https://community.traefik.io/latest.md) · [Categories](https://community.traefik.io/categories.md) · [Tags](https://community.traefik.io/tags.md)

---

## [About the Traefik v3 (latest) category](https://community.traefik.io/t/about-the-traefik-v3-latest-category/16765)

<div class="topic-metadata">

**Author:** [@ldez](https://community.traefik.io/u/ldez)\
**Replies:** 2\
**Last updated:** [July 15, 2025, 1:24pm UTC](https://community.traefik.io/t/about-the-traefik-v3-latest-category/16765 "2025-07-15T13:24:20Z")

</div>

This section is for everything related to Traefik v3.x

---

## [Traefik 3.7.13 Health Check](https://community.traefik.io/t/traefik-3-7-13-health-check/30241)

<div class="topic-metadata">

**Author:** [@blackneil](https://community.traefik.io/u/blackneil)\
**Replies:** 1\
**Last updated:** [September 14, 2026, 7:39pm UTC](https://community.traefik.io/t/traefik-3-7-13-health-check/30241 "2026-09-14T19:39:18Z")

</div>

Hello, for some test yesterday, I have added two dead services in a route with a health check, like this into the dynamic config. healthCheck: interval: 10s timeout: 3s I can quickly see the both are de…

---

## [Kubernetes Gateway provider: BackendTLSPolicy Ancestors limit exceeded](https://community.traefik.io/t/kubernetes-gateway-provider-backendtlspolicy-ancestors-limit-exceeded/29961)

<div class="topic-metadata">

**Author:** [@dklenke](https://community.traefik.io/u/dklenke)\
**Replies:** 1\
**Last updated:** [September 14, 2026, 7:40am UTC](https://community.traefik.io/t/kubernetes-gateway-provider-backendtlspolicy-ancestors-limit-exceeded/29961 "2026-09-14T07:40:35Z")

</div>

Hi, I am running traefik v3.7.5 deployed with the official helm chart 41.0.0 in Kubernetes v1.35.5. I have the Kubernetes Gateway API CRDs installed in version v1.5.1. My issue is that the Gateway API limits the List o…

---

## [Traefik not creating routers from docker labels](https://community.traefik.io/t/traefik-not-creating-routers-from-docker-labels/30235)

<div class="topic-metadata">

**Author:** [@RedToxyl](https://community.traefik.io/u/RedToxyl)\
**Replies:** 2\
**Last updated:** [September 13, 2026, 10:36am UTC](https://community.traefik.io/t/traefik-not-creating-routers-from-docker-labels/30235 "2026-09-13T10:36:16Z")

</div>

Hi there I am trying to move from a .yaml to docker labels based system. However, Traefik sometimes doesn't create routers from given docker labels. Sometimes it does, and I cannot for the life of me figure out why. Th…

---

## [Creating landing page from http endpoints](https://community.traefik.io/t/creating-landing-page-from-http-endpoints/28834)

<div class="topic-metadata">

**Author:** [@klobass-skoda](https://community.traefik.io/u/klobass-skoda)\
**Replies:** 2\
**Last updated:** [September 8, 2026, 4:07pm UTC](https://community.traefik.io/t/creating-landing-page-from-http-endpoints/28834 "2026-09-08T16:07:00Z")

</div>

Hi everyone, I've been searching for a while now for a simple way to create a basic landing page directly from an HTTP endpoints using Traefik. My goal is to have a specific path return a simple, static HTML page or ev…

---

## [ACME Cloudflare not working after 3.7.6+](https://community.traefik.io/t/acme-cloudflare-not-working-after-3-7-6/29983)

<div class="topic-metadata">

**Author:** [@dhjensen](https://community.traefik.io/u/dhjensen)\
**Replies:** 22\
**Last updated:** [September 8, 2026, 2:48pm UTC](https://community.traefik.io/t/acme-cloudflare-not-working-after-3-7-6/29983 "2026-09-08T14:48:23Z")

</div>

Hi guys, After I upgraded to version 3.7.6+ (Noticed this the first time in 3.7.8) I see the behavior in the log below. The behavior seen in the log goes away if I revert to version 3.7.5. If you need more info let me …

---

## [Traefik 3.7.12 Gateway API Setup on Kubernetes 1.36](https://community.traefik.io/t/traefik-3-7-12-gateway-api-setup-on-kubernetes-1-36/30227)

<div class="topic-metadata">

**Author:** [@kntambwe](https://community.traefik.io/u/kntambwe)\
**Replies:** 1\
**Last updated:** [September 5, 2026, 6:26pm UTC](https://community.traefik.io/t/traefik-3-7-12-gateway-api-setup-on-kubernetes-1-36/30227 "2026-09-05T18:26:34Z")

</div>

Hello Community, I am trying to setup Gateway API with traefik 3.7.12 on kubernetes 1.36. Whenever I run my yaml code to create GatewayClass, status is unknown $ kubectl get gatewayclass NAME CONTROLLER …

---

## [Error renewing ACME certificate: could not determine authoritative nameservers](https://community.traefik.io/t/error-renewing-acme-certificate-could-not-determine-authoritative-nameservers/30218)

<div class="topic-metadata">

**Author:** [@plating510](https://community.traefik.io/u/plating510)\
**Replies:** 3\
**Last updated:** [September 3, 2026, 10:52am UTC](https://community.traefik.io/t/error-renewing-acme-certificate-could-not-determine-authoritative-nameservers/30218 "2026-09-03T10:52:42Z")

</div>

I'm having trouble renewing my wildcard certificates via the DNS-01 challenge: I can see the TXT record being created at mijn.host, and then being deleted after a minute. traefik logs: traefik: ERR Error renewing ACME…

---

## [Forwarding traffic to a game server running on Pterodactyl](https://community.traefik.io/t/forwarding-traffic-to-a-game-server-running-on-pterodactyl/23657)

<div class="topic-metadata">

**Author:** [@molemanx](https://community.traefik.io/u/molemanx)\
**Replies:** 7\
**Last updated:** [August 30, 2026, 5:53am UTC](https://community.traefik.io/t/forwarding-traffic-to-a-game-server-running-on-pterodactyl/23657 "2026-08-30T05:53:13Z")

</div>

Unsure if this is the correct place for issues like this, however I’ve been trying to set up a game server running on pterodactyl over the last week and I’m on the very last hurdle. I’ve successfully set up a game serve…

---

## [Plugin integrity check fails for github.com/fosrl/badger (Pangolin's plugin) v1.6.0 and v1.6.1](https://community.traefik.io/t/plugin-integrity-check-fails-for-github-com-fosrl-badger-pangolins-plugin-v1-6-0-and-v1-6-1/30199)

<div class="topic-metadata">

**Author:** [@miloschwartz](https://community.traefik.io/u/miloschwartz)\
**Replies:** 5\
**Last updated:** [August 27, 2026, 3:43pm UTC](https://community.traefik.io/t/plugin-integrity-check-fails-for-github-com-fosrl-badger-pangolins-plugin-v1-6-0-and-v1-6-1/30199 "2026-08-27T15:43:27Z")

</div>

Hi, I'm the maintainer of the Pangolin Badger plugin (GitHub - fosrl/badger: Traefik middleware authentication bouncer for Pangolin · GitHub). We're seeing Traefik fail to install v1.6.0 and v1.6.1 with a plugin integri…

---

## [Headscale node access issues](https://community.traefik.io/t/headscale-node-access-issues/30207)

<div class="topic-metadata">

**Author:** [@boardlord1](https://community.traefik.io/u/boardlord1)\
**Replies:** 2\
**Last updated:** [August 26, 2026, 6:53am UTC](https://community.traefik.io/t/headscale-node-access-issues/30207 "2026-08-26T06:53:00Z")

</div>

I've run Headscale behind Nginx Proxy Manager without problems for a long time, but I've decided to migrate my whole reverse proxy setup to Traefik. Overall everything went fine, but I'm having problems with Headscale. T…

---

## [In k3s how to whitelist specific namespaces to work with traefik?](https://community.traefik.io/t/in-k3s-how-to-whitelist-specific-namespaces-to-work-with-traefik/29962)

<div class="topic-metadata">

**Author:** [@SpiderUnderUrBed](https://community.traefik.io/u/SpiderUnderUrBed)\
**Replies:** 1\
**Last updated:** [August 17, 2026, 7:30pm UTC](https://community.traefik.io/t/in-k3s-how-to-whitelist-specific-namespaces-to-work-with-traefik/29962 "2026-08-17T19:30:00Z")

</div>

In k3s how to whitelist specific namespaces to work with traefik? There is an allowCrossNamespace option for traefik, somewhere, helm or just in its plain setup, and I had to have enabled it because there was the UI for …

---

## [New version information on the dashboard?](https://community.traefik.io/t/new-version-information-on-the-dashboard/29999)

<div class="topic-metadata">

**Author:** [@mbender](https://community.traefik.io/u/mbender)\
**Replies:** 1\
**Last updated:** [August 17, 2026, 2:35pm UTC](https://community.traefik.io/t/new-version-information-on-the-dashboard/29999 "2026-08-17T14:35:31Z")

</div>

Is it me, or is there no notification about a new version for Traefik visible on the dashboard? Which is a bit strange because that information IS available in, say, Traefik's docker logs. Would it be possible to have t…

---

## [Per-port mTLS on the same SNI hostname — supported, or does it require distinct hostnames? (v3.7.4, Kubernetes CRD)](https://community.traefik.io/t/per-port-mtls-on-the-same-sni-hostname-supported-or-does-it-require-distinct-hostnames-v3-7-4-kubernetes-crd/29969)

<div class="topic-metadata">

**Author:** [@thelever](https://community.traefik.io/u/thelever)\
**Replies:** 1\
**Last updated:** [August 15, 2026, 12:13pm UTC](https://community.traefik.io/t/per-port-mtls-on-the-same-sni-hostname-supported-or-does-it-require-distinct-hostnames-v3-7-4-kubernetes-crd/29969 "2026-08-15T12:13:20Z")

</div>

I'm trying to serve one hostname (app.example.com) with different client-cert requirements per port: cert-free on :443 (websecure) for the browser/login routes, and RequireAndVerifyClientCert on a second entrypoint :8443…

---

## [Using the error middleware always trigger an error: "the service "@provider" does not exist"](https://community.traefik.io/t/using-the-error-middleware-always-trigger-an-error-the-service-provider-does-not-exist/29946)

<div class="topic-metadata">

**Author:** [@NotaInutilis](https://community.traefik.io/u/NotaInutilis)\
**Replies:** 5\
**Last updated:** [August 10, 2026, 1:26pm UTC](https://community.traefik.io/t/using-the-error-middleware-always-trigger-an-error-the-service-provider-does-not-exist/29946 "2026-08-10T13:26:38Z")

</div>

Hi, I'd like to ask for some help with using the error middleware with Traefik 3.7.5 on Docker. I'm getting an error which looks unrelated and I'm not sure if it's a configuration issue or a bug. I'm trying to create an…

---

## [Upgrading the chart 40.x (from 39.0.9) will block any ingress traefik](https://community.traefik.io/t/upgrading-the-chart-40-x-from-39-0-9-will-block-any-ingress-traefik/30118)

<div class="topic-metadata">

**Author:** [@EugenMayer](https://community.traefik.io/u/EugenMayer)\
**Replies:** 1\
**Last updated:** [August 8, 2026, 8:37am UTC](https://community.traefik.io/t/upgrading-the-chart-40-x-from-39-0-9-will-block-any-ingress-traefik/30118 "2026-08-08T08:37:31Z")

</div>

Env: rke2 v1.36.3+rke2r1 with 4 nodes (1 plane, 3 workers) i'am not using rke2 traefik integration/chart. I exclude ingress and deploy the traefik chart myself all nodes are barebones Kernel: 7.0.0 Ubuntu 24.04 C…

---

## [Resilient routing on invalid middlewares](https://community.traefik.io/t/resilient-routing-on-invalid-middlewares/29776)

<div class="topic-metadata">

**Author:** [@pacoguzman](https://community.traefik.io/u/pacoguzman)\
**Replies:** 3\
**Last updated:** [August 5, 2026, 8:31am UTC](https://community.traefik.io/t/resilient-routing-on-invalid-middlewares/29776 "2026-08-05T08:31:50Z")

</div>

We faced a problem when an existing router defined through an Ingress kubernetes resource is modified to add a routing middleware, if the reference to the middleware does not exist the routing will be marked as disabled …

---

## [Explain this to me like I'm 5 - Internal Cert being ignored - unable to setup](https://community.traefik.io/t/explain-this-to-me-like-im-5-internal-cert-being-ignored-unable-to-setup/30052)

<div class="topic-metadata">

**Author:** [@sham](https://community.traefik.io/u/sham)\
**Replies:** 3\
**Last updated:** [August 1, 2026, 6:51am UTC](https://community.traefik.io/t/explain-this-to-me-like-im-5-internal-cert-being-ignored-unable-to-setup/30052 "2026-08-01T06:51:06Z")

</div>

I'm not using docker, and have no idea how to figure that out, so I'm running an LXC in ProxMox. My domain is wildcard flushed through a cloudflared tunnel, all using this scripting setup: I am attempting to run nexc…

---

## [Creating an AWS ALB via  kubernetes.io/ingress.class  annotation no longer works. What is the alternative? ](https://community.traefik.io/t/creating-an-aws-alb-via-kubernetes-io-ingress-class-annotation-no-longer-works-what-is-the-alternative/29964)

<div class="topic-metadata">

**Author:** [@serene\_muskrat](https://community.traefik.io/u/serene_muskrat)\
**Replies:** 1\
**Last updated:** [July 23, 2026, 2:42pm UTC](https://community.traefik.io/t/creating-an-aws-alb-via-kubernetes-io-ingress-class-annotation-no-longer-works-what-is-the-alternative/29964 "2026-07-23T14:42:57Z")

</div>

Previously, I was able to create an AWS ALB load balancer via this configuration service: annotations: \`\`kubernetes.io/ingress.ingressClass:\`\` alb We upgraded to kubernetes 1.35, and this no longer works. W…

---

## [Traefik works but only if loadbalancer.server.port is included](https://community.traefik.io/t/traefik-works-but-only-if-loadbalancer-server-port-is-included/29970)

<div class="topic-metadata">

**Author:** [@radoeka](https://community.traefik.io/u/radoeka)\
**Replies:** 9\
**Last updated:** [July 17, 2026, 1:03pm UTC](https://community.traefik.io/t/traefik-works-but-only-if-loadbalancer-server-port-is-included/29970 "2026-07-17T13:03:55Z")

</div>

I'm very puzzled by the following, hopefully someone can shine a light on why this happening: Traefik works but only if I include the label: traefik.http.services.random-xbcz.loadbalancer.server.port: "80" But this la…

---

## [Traefik used to work perfectly, but now always falls back to default cert](https://community.traefik.io/t/traefik-used-to-work-perfectly-but-now-always-falls-back-to-default-cert/29968)

<div class="topic-metadata">

**Author:** [@pyrmion](https://community.traefik.io/u/pyrmion)\
**Replies:** 3\
**Last updated:** [July 11, 2026, 12:21pm UTC](https://community.traefik.io/t/traefik-used-to-work-perfectly-but-now-always-falls-back-to-default-cert/29968 "2026-07-11T12:21:57Z")

</div>

Hi! My Traefik setup was working perfectly. And then all of a sudden Traefik started serving not the certificates it requested via cloudflare/let's encrypt but the fallback Traefik one. I setup Traefik completely new …

---

## [HTTP/3 not working with proxy protocol enabled](https://community.traefik.io/t/http-3-not-working-with-proxy-protocol-enabled/29963)

<div class="topic-metadata">

**Author:** [@ben.ganley](https://community.traefik.io/u/ben.ganley)\
**Replies:** 0\
**Last updated:** [July 7, 2026, 5:53am UTC](https://community.traefik.io/t/http-3-not-working-with-proxy-protocol-enabled/29963 "2026-07-07T05:53:03Z")

</div>

Hi there, We're running traefik in EKS behind an NLB. We're attempting to roll out support for HTTP3 but are running into issues when the target group has Proxy Protocol enabled. Naturally we don't expect this to work …

---

## [forwardauth.maxBodySize and forwardAuth.maxResponseBodySize have not been able to bet set](https://community.traefik.io/t/forwardauth-maxbodysize-and-forwardauth-maxresponsebodysize-have-not-been-able-to-bet-set/29955)

<div class="topic-metadata">

**Author:** [@bastiane273](https://community.traefik.io/u/bastiane273)\
**Replies:** 0\
**Last updated:** [June 28, 2026, 9:28pm UTC](https://community.traefik.io/t/forwardauth-maxbodysize-and-forwardauth-maxresponsebodysize-have-not-been-able-to-bet-set/29955 "2026-06-28T21:28:01Z")

</div>

I am using the middleware for the crowdsec Bouncer: EntryPoint Websecure: websecure: address: ':443' http: middlewares: traefik-crowdsec-bouncer@file Definition Middleware http: middlewares: traefi…

---

## [ACME: "server misbehaving"](https://community.traefik.io/t/acme-server-misbehaving/29951)

<div class="topic-metadata">

**Author:** [@precariousDolphin](https://community.traefik.io/u/precariousDolphin)\
**Replies:** 2\
**Last updated:** [June 28, 2026, 9:42am UTC](https://community.traefik.io/t/acme-server-misbehaving/29951 "2026-06-28T09:42:42Z")

</div>

Today I received notifications that me server certificates have expired. The logfile entries say this. 2026-06-26T11:44:19Z INF Error renewing ACME certificate: {Main:nextcloud.domain.one SANs:\[\]} error="get directory a…

---

## [Traefik OTLP logs to azure app insights/log analytics workspace](https://community.traefik.io/t/traefik-otlp-logs-to-azure-app-insights-log-analytics-workspace/29947)

<div class="topic-metadata">

**Author:** [@YeswanthReddyPR](https://community.traefik.io/u/YeswanthReddyPR)\
**Replies:** 1\
**Last updated:** [June 26, 2026, 8:55am UTC](https://community.traefik.io/t/traefik-otlp-logs-to-azure-app-insights-log-analytics-workspace/29947 "2026-06-26T08:55:34Z")

</div>

Hi @everyone Can anyone confirm is the traefik otlp supports the azure app insights and azure application insights. Thanks, P R Yeswanth Reddy

---

## [Error: UPGRADE FAILED: failed to create resource: admission webhook "validate.kyverno.svc-fail" denied the request:](https://community.traefik.io/t/error-upgrade-failed-failed-to-create-resource-admission-webhook-validate-kyverno-svc-fail-denied-the-request/29941)

<div class="topic-metadata">

**Author:** [@amino95](https://community.traefik.io/u/amino95)\
**Replies:** 0\
**Last updated:** [June 15, 2026, 8:59pm UTC](https://community.traefik.io/t/error-upgrade-failed-failed-to-create-resource-admission-webhook-validate-kyverno-svc-fail-denied-the-request/29941 "2026-06-15T20:59:14Z")

</div>

Hello, i can't resolve this error when trying to migrate from nginx ingress to traefik via Helm templates. I already have an helm chart already deployed on a private cluster so i can't install the original traefik helm c…

---

## [TCP catch all only working with TLS](https://community.traefik.io/t/tcp-catch-all-only-working-with-tls/29940)

<div class="topic-metadata">

**Author:** [@juffma](https://community.traefik.io/u/juffma)\
**Replies:** 4\
**Last updated:** [June 15, 2026, 1:59pm UTC](https://community.traefik.io/t/tcp-catch-all-only-working-with-tls/29940 "2026-06-15T13:59:43Z")

</div>

I'm trying to expose coturn TCP over Traefik (latest version 3.7.5). Yet I've hit a wall where Traefik will only forwards TLS traffic. Naturally I've set up a TCP router (with TLS passthrough since coturn runs TCP/TLS a…

---

## [Traefik OOM issue](https://community.traefik.io/t/traefik-oom-issue/29022)

<div class="topic-metadata">

**Author:** [@krobbo](https://community.traefik.io/u/krobbo)\
**Replies:** 2\
**Last updated:** [June 15, 2026, 6:13am UTC](https://community.traefik.io/t/traefik-oom-issue/29022 "2026-06-15T06:13:36Z")

</div>

We are running traefik 3.5 and over the weekend noticed a few of our pods having an OOM error, for months they have ran at between 1.2-1.6G, we have the request/limit set at 2G. At the same time as the OOM errors we noti…

---

## [Extremely high CPU usage with WireGuard](https://community.traefik.io/t/extremely-high-cpu-usage-with-wireguard/25401)

<div class="topic-metadata">

**Author:** [@LegendaryFire](https://community.traefik.io/u/LegendaryFire)\
**Replies:** 2\
**Last updated:** [June 15, 2026, 6:13am UTC](https://community.traefik.io/t/extremely-high-cpu-usage-with-wireguard/25401 "2026-06-15T06:13:14Z")

</div>

I have Traefik configured in Docker, and WireGuard is working fine but I noticed when uploading a large file to my server, Traefik CPU usage uses up every bit of my CPU utilization on an Intel i3 12100. The labels I'm r…

---

## [ Plugin published with all requirements met, no catalog discovery after 3 days, no traefiker-bot issue](https://community.traefik.io/t/plugin-published-with-all-requirements-met-no-catalog-discovery-after-3-days-no-traefiker-bot-issue/29927)

<div class="topic-metadata">

**Author:** [@jeroentrappers](https://community.traefik.io/u/jeroentrappers)\
**Replies:** 0\
**Last updated:** [June 8, 2026, 11:43am UTC](https://community.traefik.io/t/plugin-published-with-all-requirements-met-no-catalog-discovery-after-3-days-no-traefiker-bot-issue/29927 "2026-06-08T11:43:31Z")

</div>

Hi all, I published a small Traefik v3 middleware plugin three days ago and it hasn't been picked up by the catalog yet. Following the Plugin Development Guide I added the traefik-plugin topic at 2026-06-05 10:31 UTC,…

[Next page](https://community.traefik.io/c/traefik/traefik-v3/21.md?page=1)
